Disable x11 password menu prompt



  • I am using openssh on two different level suse boxes from the command prompt and on one system I get an X11 menu prompt for the password and I want to disable that.

    Supposedly from other places I have read that has to do with the env vars of DISPLAY and SSH_ASKPASS

    On the system where I don't get the prompt

    ssh -v is: OpenSSH_4.4p1 OpenSSL 0.9.8d 28 Sept 2006
    DISPLAY=:0
    SSH_ASKPASS=/usr/lib/ssh/x11-ssh-askpass

    On the system where I DO get the prompt that I want to get rid of:

    ssh -v is: OpenSSH_4.2p1 OpenSSL 0.9.8a 11 Oct 2005
    DISPLAY=:0.0
    SSH_ASKPASS is not set (tho the /usr/lib/ssh programs do exist)

    I tried setting SSH_ASKPASS  to /usr/lib/ssh/x11-ssh-askpass and setting DISPLAY=:0 but that didn;t get rid of the menu prompt.

    Any suggestions?


Locked