[SOLVED] pfSense, MacBook and Blank Pages



  • Hey guys,

    Coming from a pure Windows background, I now have a MacBook Pro. However, for some reason I'm having a strange issue where accessing some pages results in a blank page.

    I'm a uni student (albeit with a penchant for technical stuff) doing a humanities subject so finding journals and references is like second to breathing. The university I go has a search thing - it uses SSO (UK Federation access to access stuff from databases). This works perfectly on Windows PC's with pfSense set up as-is. However, it does not work with Mac.

    I tried using a portable hotspot to test - when using the portable hotspot, it works perfectly. I can access everything. When using the connection coming through pfSense, it doesn't work.

    Ive tried fiddling with iPv6 to see if that was causing it (as PlusNet in the UK hasn't deployed it) but disabling it on the macOS network preferences hasn't fixed it, neither has disabling it on pfSense (for LAN and WAN).

    In light of the MacBook being the only machine that cannot access it whereas all Windows machines can (and that using a portable hotspot allows access on the Mac), anyone have any ideas as to whats going on?

    ![Screenshot 2016-12-10 13.59.31.png](/public/imported_attachments/1/Screenshot 2016-12-10 13.59.31.png)
    ![Screenshot 2016-12-10 13.59.31.png_thumb](/public/imported_attachments/1/Screenshot 2016-12-10 13.59.31.png_thumb)



  • It's not OSX as I run all pfsense machines I administrate via MacOS.



  • Well, it's now solved. Wasn't pfSense at all. Rather, ESET was screwing everything up.

    Only found this out through trial-and-error reinstall. Apparently, it simply does not like when a network is set as 'Home', but with a public network it all works. Obviously with a public network sharing becomes a hassle so…

    Anyway, back to writing up the paper  ::)