Telekom VOIP Einstellungen bei 2.3.2-RELEASE-p1 (i386)



  • Hallo, also ich habe volgendes:

    Telekom VDSL2 mit 50 Mbit
    Modem: Vigor 130
    Router: pfsense 2.3.2-RELEASE-p1 (i386)
    und dann ne fritzbox 7330 SL für ip telefonie

    als ich noch den speedport dran hatte und da die Fritz angeschlossen hab, hat die Telefonie 1A funktioniert
    nur seit ich pfsense hab eben nicht mehr, habe etliche anleitungen gefunden und jede sagt was anderes oder die screenshots passen sich zu meiner version von pfsense, ich hab da teilweise ganz andere einstell möglichkeiten :(

    kann mit dabei jemand helfen? würde echt ungerne wieder alles abbauen und den speedport nutzen, weil Internet funktioniert ja und das sehr gut sogar (bis auf ipv6 das muss ich noch rausfinden wie das funktioniert)


  • Moderator

    Hi,

    Hast du das angepinnte Howto überhaupt schon gelesen?

    -> https://forum.pfsense.org/index.php?topic=120063.0



  • Ja und wenn ich das Machen will:

    2. Unter Firewall ->NAT ->Outbound Eine neue Regel erstellen:
    Interface: WAN
    Protocol: UDP
    Source: IP/Alias des Telefons/FritzBox
    Address: Interface Address
    Port: Static Port anhaken

    wird da noch ein port verlangt ??? und die sourch ip wird von 192.168.1.20 (fritz box) zu 192.168.1.0 umgewandelt

    so schaut das bei mir aus https://gyazo.com/cc89dadf3f26f8868216d75a2ebe85c1


  • Moderator

    Und wo ist daran das Problem? :)

    Das Port Feld ist zur Eingabe da aber ja keine Pflicht. Einfach leerlassen für ALLE Ports? Das wird nur gebraucht, damit die IP des Telefons oder der Fritte mit allen Ports 1:1 nach draußen gemappt wird, also ein abgehender Port 5000 auch nach NAT noch Port 5000 ist und nicht plötzlich zu 9278 wird.

    Dein Screenshot sieht doch gut aus. Unten bei Translation noch Haken rein bei Static und gut. Gibt es BTW einen spezifischen Grund, dass du i386 einsetzt?



  • Bei mir funktioniert VoIP am Telekom-Anschluss ohne Portweiterleitungen oder andere Einstellungen auf der pfSense, da die Telekom symmetrisches RTP zu benutzen scheint (https://forum.pfsense.org/index.php?topic=89846.msg500497#msg500497).

    Ich benutze als VoIP-Telefon ein Gigaset SL450A GO. Hier ist es wichtig STUN abzuschalten(!) und darauf zu achten, dass die NAT-Refreshzeit unterhalb des Timeouts der Stateful Packet Inspektion für UDP liegt. Wenn die Firewall Optimization Option auf "normal" steht, sind das die Time-Outs, die als default eingestellt sind (# pfctl -s timeouts):

    
    ...
    udp.first       60s
    udp.single    30s
    udp.multiple 60s
    ...
    
    

    Die NAT-Refreshzeit steht im SL450AGO auf 20 Sekunden, liegt also deutlich darunter.

    Das Setup läuft bei mir seit Januar ohne Probleme.



  • ok habs hinbekommen, lag wirklich nur an den ports, und ich hab das 32bit weil das ganze auf einen Futro S500 läuft und das sehr flüssig und ohne probleme :D


  • Moderator

    Ich mag mich ja täuschen, aber der Futro S500 läuft nach eigenen Angaben mit einem AMD Sempron 2100+. Das ist eine 64Bit CPU wenn ich nicht völlig blind bin, deshalb frage ich mich schon, warum da die 32bit Variante genutzt wird, zumal mit 2.3.x die letzte Version erreicht sein dürfte, mit der pfSense 32bit unterstützt. Darum vielleicht der Hinweis, dass du ggf. die 64bit Variante testen solltest, wenn du zukünftig nicht nur 2.3 als LTS Variante nutzen, sondern auch auf 2.4 weiter updaten möchtest.



  • Jap läuft jetzt als 64Bit :D