Email - GSuite



  • Added our external IP to allowed relay

    Still having issues getting test email to go through..

    not sure what I'm missing…

    smtp-relay.gmail.com
    465
    STMP over SSL/TLS
    from - notify@ <ourdomain>email - <me>@ <ourdomain>auth user - <me>@ <ourdomain>Auth pass - <my gsuite="" pass)<br="">email auth mech - Plain

    Error: 534-5.7.14

    Reading it shows I need to change my password - change it might work...
    Trying this - will report back</my></ourdomain></me></ourdomain></me></ourdomain>



  • Since you're providing a user/pass, perhaps your email auth mechanism should be LOGIN?  You can also try using port 587.  Notifications work for me with Office365.  Port 587, uncheck SMTP over SSL/TLS, check Enable STARTTLS, email auth mech is LOGIN.  Works like a charm.



  • Actually was getting denied due to apps having insecure apps signin being blocked…

    • had to go in and create another user in a sub org - vs moving my acct.
      from there set the permissions for that org to allow user to set to allow less secure apps.

    sign in from that user account -
    https://support.google.com/accounts/answer/6010255?hl=en
    use the link there to > http://www.google.com/settings/security/lesssecureapps
    and allow / change to allow.

    once I did that

    Changed the settings again to match that account and it went through without an issue..
    Also set a more strict password and documented that elsewhere though.

    GSuite was calling that method an insecure signin - once allowed it worked fine.

    (also changed to Login vs Plain - but that didn't help until I changed the insecure app allowed.

    new settings

    smtp-relay.gmail.com
    465
    STMP over SSL/TLS
    from - <notify other="">@ <ourdomain>email - <me>@ <ourdomain>auth user - <new>@ <ourdomain>Auth pass - <new gsuite="" pass)<br="">email auth mech - Login

    <new>= new dedicated user with insecure app access allowed on that one acct.

    • fwd email filter from that acct to my acct so I can monitor for issues with that acct.</new></new></ourdomain></new></ourdomain></me></ourdomain></notify>


  • Oh right, I forgot you have to authorize apps to access your Google stuff.  Thanks for the reminder.