DHCP Relay to DHCP on Domain Contoller



  • Hello,

    I have a domain controller configured with DNS and DHCP on subnet A.  I would like to create a new subnet, Subnet B, to simulate a subnet on the same domain.  I would like for the subnet B computers to get their IP address from the domain controller on subnet A.  I am using the most current version of pfSense and setup the settings similar to my pfSense router on subnet A.

    I can assign a static IP address to the clients on subnet B but if I try to have them receive an automatic IP assignment from DHCP on subnet A it does not work.  I setup a new subnet in the Domain Controller (sites and services) on subnet A to account for the IP address range on subnet B.  I setup a new IPv4 scope in DHCP for subnet B.  I read online that DNS forward or reverse lookup zones do not need to be configured for subnet B (could be wrong though)

    I tried so many different settings in pfSense but I haven't figured out the right combination.  I tried DHCP relay for LAN, then I tried WAN and LAN, and neither worked.  I tried playing with the DNS settings (DNS Forward and Relay) but that did not work either.

    I would appreciate any help or other posts I should read to try and get this running smoothly.  Thank you in advance!

    Scenario I'm trying to achieve
    Subnet B(pfSense router) –> Subnet A (pfSense router)--> WAN

    Subnet A - 192.168.10.0/24
    Domain Name:  train.local
    Domain Controller:  192.168.10.12
    Default Gateway:  192.168.10.1
    DNS and DHCP are configured on Win Server 2012 R2
    EM1 = WAN - 192.168.2.1 (DHCP assigned by upstream router)
    EM0 = LAN - 192.168.10.1 (static IP - DHCP turned off on pfSense)

    Subnet B - 192.168.4.0/24
    EM1 = WAN - 192.168.10.20 (DHCP assigned by DC01.train.local)
    EM0 = LAN - 192.168.4.1 (static IP - DHCP turned off on pfSense)


  • Banned

    You'd better use a recent 2.3.3 snapshot to use DHCP relay.



  • So Dhcp relay is not working until 2.3.3?
    Thanks a lot.


  • Banned

    Yeah, it's not working with 2.3.2-* at all. It worked with 2.3.1, it's been working for a while with 2.3.3 snapshots. (Filed multiple bugs about it, so I'm very very sure it just does not work with 2.3.2)



  • Actually, I use old version 2.1.3  :-
    I'm just wondering Dhcp relay ever works before as I hit problems configure it.


  • Banned

    Well, 2.1.3 is something you definitely should NOT be using, DHCP relay or not.


Log in to reply