SG-1000 speed issues



  • Hi there, I just opened and set up my new SG-1000. Bravo!

    Before it was set up: I am receiving 88mbps down tonight when I directly connect my laptop to my modem, per google's speed test.

    After it was set up: However, with pfsense, when directly connected to the SG-1000 I am only receiving 10-15mbp down per google's speed test. I power-cycled my modem a few times and am unfortunately still receiving the same speeds.

    I purchased the SG-1000 because I thought it had a gigabit connection or at least 100gbp down… however I am seeing a fraction of this in practice.

    Am I missing a setup issue?



  • Hi, i received my sg-1000 and have unfortunately the same result, troughput is really low.
    i did a test with a celeron 1Ghz on a board with dual 100Mb ethernet , connexion was 60Mbits compare to direct connexion around 90. The sg-1000 is giving 18/ 35.

    Too much loss, i was expecting a lot better :(.

    i tries again, my connexion is a bit slow today,
    SG-1000 : 8Mb down , 3 mb up
    Celeron 1Ghz : 30Mb down, 3 mbup
    direct connexion to modem  : 39 / 3


  • Netgate Administrator

    Are you seeing similar results to multiple test servers?

    How about just downloading a file from a known high speed source?

    I would not expect the SG-1000 to introduce any sort of a restriction on a connection that's less than 100Mbps.

    Are you seeing any errors on the interfaces?

    Any variation between snapshots?

    Steve



  • Hi, i'm doing a simple speedtest with my internet provider (cable connection).
    Speed is changing a bit from 30 to 40Mb , but i haave always the same ratio with the sg-1000, i'm around 33%.

    i'm using version 2.3. on my celeron, the one on the sg-1000 is 2.4 beta

    BR
    Gaetan


  • Rebel Alliance Developer Netgate

    Is it the same configuration on both systems? What features are enabled?

    What is the CPU usage like on the SG-1000 during the test? ("top -aSH" from a shell prompt)

    Are there any interface errors showing on Status > Interfaces? What does the interface speed/duplex show?



  • Hey there, I opened a ticket with customer support and we are working through some strategies. Something however that really helped was this:

    Interfaces -> WAN -> General Configuration, change Speed and Duplex from automatic to 100base TX full-duplex. With that change, I've bumped up my speed test from 10-15mbs to 40-50mbps. I don't know why telling it explicitly which speed to use helped, but it did.

    I am seeing CPU usage a little high during speed tests (~60% CPU usage), so we are going to debug a bit more to see if we can get it closer to the speed w/o the device (90mbs).



  • Came here to report the same thing. My former "homebrew" pfsense box runs 130-140 Mbits/s without fail. However, as soon as I hooked up the SG-1000 (with same configuration otherwise) I drop to 15-30 Mbits/s. (See attached, before 1/7/17 vs after.)

    This is probably actually fast enough for 85% of our normal residential use, but I would access to the full speeds I pay for.

    I tried the WAN speed setting that skilbjo mentions above, but it didn't seem to do anything in quick testing. (but I'll try it for a few days and see what happens.)

    Any other advice? Worth putting in a ticket for this?

    thanks
    Matt

    ![Screenshot 2017-01-08 at 9.18.48 AM.png](/public/imported_attachments/1/Screenshot 2017-01-08 at 9.18.48 AM.png)
    ![Screenshot 2017-01-08 at 9.18.48 AM.png_thumb](/public/imported_attachments/1/Screenshot 2017-01-08 at 9.18.48 AM.png_thumb)


  • Rebel Alliance Developer Netgate

    See my post a few entries up and post the items I mentioned, also, post the output of this command:

    sysctl -a | grep cpsw
    


  • thanks. will get to the items you mentioned. meanwhile, here is the output of sysctl -a | grep cpsw from my box:

    
    Shell Output - sysctl -a | grep cpsw
    dev.etherswitch.0.%parent: cpswss0
    dev.miibus.1.%parent: cpsw1
    dev.miibus.0.%parent: cpsw0
    dev.cpsw.1.%parent: cpswss0
    dev.cpsw.1.%pnpinfo:
    dev.cpsw.1.%location:
    dev.cpsw.1.%driver: cpsw
    dev.cpsw.1.%desc: Ethernet Switch Port
    dev.cpsw.0.%parent: cpswss0
    dev.cpsw.0.%pnpinfo:
    dev.cpsw.0.%location:
    dev.cpsw.0.%driver: cpsw
    dev.cpsw.0.%desc: Ethernet Switch Port
    dev.cpsw.%parent:
    dev.cpswss.0.watchdog.resets: 0
    dev.cpswss.0.queue.rx.longestChain: 0
    dev.cpswss.0.queue.rx.queueRestart: 0
    dev.cpswss.0.queue.rx.totalDequeued: 3838177
    dev.cpswss.0.queue.rx.totalEnqueued: 3838561
    dev.cpswss.0.queue.rx.maxAvailBuffers: 110
    dev.cpswss.0.queue.rx.availBuffers: 0
    dev.cpswss.0.queue.rx.maxActiveBuffers: 384
    dev.cpswss.0.queue.rx.activeBuffers: 384
    dev.cpswss.0.queue.rx.totalBuffers: 384
    dev.cpswss.0.queue.tx.longestChain: 6
    dev.cpswss.0.queue.tx.queueRestart: 0
    dev.cpswss.0.queue.tx.totalDequeued: 4563228
    dev.cpswss.0.queue.tx.totalEnqueued: 4563228
    dev.cpswss.0.queue.tx.maxAvailBuffers: 128
    dev.cpswss.0.queue.tx.availBuffers: 128
    dev.cpswss.0.queue.tx.maxActiveBuffers: 8
    dev.cpswss.0.queue.tx.activeBuffers: 0
    dev.cpswss.0.queue.tx.totalBuffers: 128
    dev.cpswss.0.stats.GoodRxFrames: 3880465
    dev.cpswss.0.stats.BroadcastRxFrames: 14793
    dev.cpswss.0.stats.MulticastRxFrames: 40445
    dev.cpswss.0.stats.PauseRxFrames: 0
    dev.cpswss.0.stats.RxCrcErrors: 293
    dev.cpswss.0.stats.RxAlignErrors: 103
    dev.cpswss.0.stats.OversizeRxFrames: 0
    dev.cpswss.0.stats.RxJabbers: 0
    dev.cpswss.0.stats.ShortRxFrames: 0
    dev.cpswss.0.stats.RxFragments: 4479
    dev.cpswss.0.stats.RxOctets: 3514843195
    dev.cpswss.0.stats.GoodTxFrames: 4009902
    dev.cpswss.0.stats.BroadcastTxFrames: 236
    dev.cpswss.0.stats.MulticastTxFrames: 1960
    dev.cpswss.0.stats.PauseTxFrames: 0
    dev.cpswss.0.stats.DeferredTxFrames: 0
    dev.cpswss.0.stats.CollisionsTxFrames: 0
    dev.cpswss.0.stats.SingleCollisionTxFrames: 0
    dev.cpswss.0.stats.MultipleCollisionTxFrames: 0
    dev.cpswss.0.stats.ExcessiveCollisions: 0
    dev.cpswss.0.stats.LateCollisions: 0
    dev.cpswss.0.stats.TxUnderrun: 0
    dev.cpswss.0.stats.CarrierSenseErrors: 0
    dev.cpswss.0.stats.TxOctets: 3559792735
    dev.cpswss.0.stats.RxTx64OctetFrames: 69663
    dev.cpswss.0.stats.RxTx65to127OctetFrames: 2387733
    dev.cpswss.0.stats.RxTx128to255OctetFrames: 320328
    dev.cpswss.0.stats.RxTx256to511OctetFrames: 344107
    dev.cpswss.0.stats.RxTx512to1024OctetFrames: 334674
    dev.cpswss.0.stats.RxTx1024upOctetFrames: 4434261
    dev.cpswss.0.stats.NetOctets: 7074772555
    dev.cpswss.0.stats.RxStartOfFrameOverruns: 2
    dev.cpswss.0.stats.RxMiddleOfFrameOverruns: 0
    dev.cpswss.0.stats.RxDmaOverruns: 0
    dev.cpswss.0.ports.1.uptime: 14359
    dev.cpswss.0.ports.0.uptime: 14361
    dev.cpswss.0.intr_coalesce_us: 0
    dev.cpswss.0.attachedSecs: 14505
    dev.cpswss.0.rx_batch: 0
    dev.cpswss.0.debug: 0
    dev.cpswss.0.%parent: simplebus0
    dev.cpswss.0.%pnpinfo: name=ethernet@4a100000 compat=ti,am335x-cpsw
    dev.cpswss.0.%location:
    dev.cpswss.0.%driver: cpswss
    dev.cpswss.0.%desc: 3-port Switch Ethernet Subsystem
    dev.cpswss.%parent:
    
    

  • Rebel Alliance Developer Netgate

    dev.cpswss.0.stats.RxCrcErrors: 293
    dev.cpswss.0.stats.RxAlignErrors: 103
    

    That would seem to imply that one of the ports (unfortunately it doesn't know which) was receiving some bad data from its peer. Though in other "slow" cases we've seen these counters much, much higher.

    It could be an indication of a cabling or speed negotiation problem, but it's usually at L1 or L2. Swap cables/ports, check speed/duplex, etc.



  • These things are perfect for our redundant T1 lines.

    Check sig.


Log in to reply