Windows: Network name changing on pfSense router reboot



  • I've got a router running 2.3.2-release, with additional 2 and 4-port network cards installed, bridged to create a single LAN interface. My windows machine is connected directly to one of the bridged LAN ports, and generally works fine. However, when I reboot the router, the Windows machine tells me I've connected to a new network, and asks me to identify whether it's public or private; it also assigns a new name - so far I'm up to "Network 24". The MAC address of the ethernet port to which the Windows machine is connected hasn't changed - any idea what could be causing this?



  • no clue why that is, but you could stop this bridging nonsense and get a $5 switch



  • Calling it "nonsense" without understanding the use case I have is ridiculously condescending. In my case, I've chosen to bridge the ports to that I can use ntopng on the router to monitor traffic between nodes; with a $5 switch I wouldn't see that traffic. I'm not, in general, bottlenecked on my connections between local nodes so I fail to see the disadvantage of using bridging in pfSense rather than a switch. Feel free to enlighten me if I've missed something, but if you do, then please take the time to do so in a more constructive way.



  • So I actually just had this problem too, it was a pain to figure out so I figured I'd make an account to help you out. The issue is with the mac address on your default gateway. You likely do not have a mac address assigned to your bridge connection. I would assume you use your bridge as your default gateway so go to interface -> bridge You need to assign a mac address because if you have nothing manually entered, pf-sense gets a new mac address whenever the system is rebooted. This causes windows to see it as a new network. But please DO NOT assign any random mac address to the the interface. It completely breaks the network. You need to find out what mac address is currently assigned to the default gateway interface. If using a windows system you can open the command prompt and type "arp -a" and it will give you the mac address of everything it can see on the network. Give your bridge interface, or whatever your default gateway interface is, the mac address you see for your current default gateway. Everything will continue to operate fine without a reboot of the pf-sense box. Let me know if it doesn't work. I still get the name of "Network 30" but the number has not changed.



  • Setting the MAC address on the bridged interface looks like it will do exactly what I want - thanks! Note that you can change the "Network 30" name to whatever you want by following the instructions here: https://www.tenforums.com/tutorials/28375-network-profile-name-rename-windows-10-a.html


Log in to reply