Enabling Multicast for Yatse auto-detection wizard



  • Been using PFSense for a few months now and LOVE it.  So first and foremost, thanks to everyone that makes it possible.

    A snag I've hit is that Yatse, a popular Android remote for Kodi, no longer auto-detects my currently running Kodi instances when running the Add Host Setup Wizard.  That is, when my Android phone or tablet starts the Host Setup Wizard in the Yatse app while connected to the same LAN as the currently running host, it still doesn't auto find it.  This used to work, and I can still manually add the host, but it'd be nice to get this working (because I'm sure this is affecting other applications I'm unaware of yet).

    In the Yatse troubleshooting page (http://yatse.tv/redmine/projects/yatse/wiki/XbmcConfig) it states what I think is the relevant issue: "Auto-detection of hosts requires multicast. Some routers does not support this or will block them by default. This will block Yatse auto-detection."

    I assume this is the issue and there are a few posts on here I've found detailing why Multicasting isn't working as expected for certain users, but all those use-cases seem far more complicated than mine (across subnets etc).  Here is a screenshot of my LAN rules: https://www.dropbox.com/s/3g6in5z2xiy9h25/Screen Shot 2017-01-02 at 9.19.04 PM.png?dl=0

    Could someone please advise me how to enable multicast on my local LAN (and sorry if this is a dumb/easy question)?



  • I've found the easiest way to solve this problem is to enable IGMP snooping on your switch (if you have one).

    Also, have you setup the Avahi package?


  • LAYER 8 Global Moderator

    Multicast not working on the same layer 2, ie lan has zero to do with pfsense..

    jamesonp is on the right track - what switch do you have or what wifi are these devices on?  Its quite possible to block multicast at the switch level or have an issue with your AP of your wifi to be blocking multicast..

    And your sure these devices trying to find each other via multicast are on the same layer 2 network?



  • @johnpoz & @jamesonp thanks so much for your responses and for taking the time! I'm sorry for my delay in responding, I assumed I would get an alert when a reply was posted but thankfully I checked tonight for good measure.

    To reiterate, multicast not working was just my best educated guess based on what I read and the fact that the pfsense router was the only thing that changed.  My setup is Wan->SB6121 Modem->PFsense on Zotac Intel N3150->Trendnet unmanaged gigabit TEG-S16DG Switch->Asus RT-N66U acting solely as an Access Point.  In this flow, there used to be a Netgear WNDR3700 running DD-WRT, and slotting the PFsense box in as the router is the only thing that I've changed since Yatse's Auto-Detection Wizard stopped working.  So I may be way off and fundamentally misunderstand the issue, but I thought with my LAN rules so generic and all inclusive and the Yatse page specifically mentioning Multicast as something the wizard needs (that is blocked by default on some routers) I thought this was my best bet.

    To answer your specific questions @jamesonp I haven't setup the avahi package.  I had only installed OpenVPN and Darkstat.  So I downloaded it from the Package Manager since I gathered from your question that it was pertinent:)  Some light googling led me to believe that it is zeroconf/bonjour, that accurate? So, this seems like a good place to start, any suggestions on settings?  Installing it and making zero changes and not restarting pfsense didn't get the wizard to work, if you can believe that:)

    and to both of you: I believe since i have an unmanaged switch (again the Trendnet TEG-S16DG), I'm guessing enabling anything on it wouldn't really be possible (i've never made any configuration changes to it before).  But if this is wrong please let me know and I'll investigate IGMP further (and how to make changes on it).  Also I haven't been focusing on that, or any of the other components, cause this Yatse wizard worked before I swapped out pfsense and nothing else has changed.

    Thanks again!

    edit: just realized I missed a few questions: the Kodi instances have ethernet cables plugged in that go into the Trendnet Switch.  And my Android is either on my 2.4ghz or 5.0ghz Wifi network, both which are in the same Lan.  At least i'm pretty sure they are, layer 2 network is a new term I've seen a few times in my pfsense adventure but not one I'm 100% comfortable with.  I'm assuming it refers to the network you set up at home, one step away from WAN, or the LAN, if that's the case then, i'm near positive they are on the same Layer 2 Network.  But please let me know if you'd like me to clarify further


  • LAYER 8 Global Moderator

    Layer 2 in simple terms is the wire in a network.. Nothing more your layer 3 network runs on top of that wire, ie your 192.168.1/24 network.

    If your on the same "wire" (dumb switch) or wifi bridge to your network (access point) then your on the same layer 2 network.. And again going to say this pfsense has ZERO to do with traffic over your wifi to devices on your switch.. ZERO.. pfsense is the gateway off your network!!  ie from your network to the internet.  devices wanting to talk to each on your network wouldn't care if if pfsense was on or off..

    Now they might use it for dns, to find your machines by name.  But a device on your switch wanting to talk to another device on your switch could care if pfsense was there or not.  Same goes for your wifi devices..  You really need to look elsewhere for your problem.

    You should look to AP if your having problems with multicast beween your wired and wireless devices.



  • @johnpoz again thanks for the reply.  I appreciate the disparity in our knowledge and harbor no doubts that you are right, and that pfsense has "ZERO" to do with traffic over my wifi.  Like I said, that was just my best bet based on my limited knowledge on the subject.

    But the fact remains, that this worked for me, then I swapped my DD-WRT Router for a intel box running pfsense and now it no longer works.  So it seems illogical for it NOT to have SOMETHING to do with pfsense setup, either directly or in some setting i perhaps needed to change on one of my other devices.  My AP is simply in Access Point mode and really doesn't have many settings to set, plus it is an almost identical setup to how it had been previously under DD-WRT (the only change I made was that when I set up pfsense I changed my Layer 3 (thanks for teaching me that!) subnet from 192.168.1.x to 10.10.10.x).

    So from what I can tell, there are 2 threads out there which might be actionable for my issue:

    @jamesnp suggestion of installing avahi.  Which I did, but I could use some help on the settings.  For instance, I couldn't figure out how to remove LAN from the "Deny Interfaces" section, til i accessed the GUI on my phone and that section turned into a drop-down with checkboxes.

    2. You mentioned DNS.  One of my early hurdles with PFsense was getting DNS to be recognized when I connected over VPN.  Though I feel like the IP address would show up instead of the hostname if this was the issue.  Also you define the instances name inside Kodi's settings, so I kind of doubt this is the issue but I'm just trying to be a completist.  FWIW I'm using DNS Resolver on all Network Interfaces and Register DHCP leases and Register Static mappings.

    Anything else I should try?  Also inside the Kodi is the ability to set the port to connect to, which I haven't changed.  I believe it defaults to 8080, maybe its a conflict?  Since I set my LAN to allow everything to everything inside it (see the screenshot in my first post) I assume I didn't need to forward anything but maybe that's wrong?  Is there some kind of forward I should set up?  I think tonight i'll try changing that port to something random and see what happens.


  • LAYER 8 Global Moderator

    Avahi can help when you need to use multicast dns (mdns) across networks..

    dude lets go over this one last time!!!  Pfsense has ZERO to do with multicast on the same layer2/broadcast domain – ZERO!!!  Not sure what you did when you swapped out what you had before to pfsense but pfsense has nothing to do with this..

    Sorry that is just how it works.. My guess would be more to changing your layer 3 network from 192.168 to some 10 based network.. Can you manually access vs using multicast for auto discovery?  I really do not want to have to download this crap to learn how it works ;)  But what I am telling you is pfsense has ZERO to do with this..



  • Ok based on your latest reply with your new network layout, I'm guessing your AP has wireless multicast forwarding disabled.

    Does your web interface look like the link below?

    http://event.asus.com/2012/nw/dummy_ui/en/Advanced_WAdvanced_Content.html

    If so, enable the "Wireless Multicast Forwarding" option.  I've never dealt with any Asus products but on some wireless APs you have to enable the transmission/receiving of multicast traffic for wireless clients.  I think that's probably this option on your device.


  • LAYER 8 Global Moderator

    ^ yeah there you go.. That would be an issue for sure!!

    A thank you and applaud from me, just because you took the time to post up pic of the interface showing that wifi router can block that sort of stuff ;)  There you go RickyBaker there is your problem.. Pretty much freaking Guarantee it!!!



  • @johnpoz:

    dude lets go over this one last time!!!  Pfsense has ZERO to do with multicast on the same layer2/broadcast domain – ZERO!!!  Not sure what you did when you swapped out what you had before to pfsense but pfsense has nothing to do with this..

    I Believe you! I swear!

    @johnpoz:

    Can you manually access vs using multicast for auto discovery?

    I can! so no need to download/test anything.  I'm mostly trouble shooting this because I'm concerned this issue, WHATEVER it may be ;), may manifest itself in the future in other forms

    @jamesonp:

    Ok based on your latest reply with your new network layout, I'm guessing your AP has wireless multicast forwarding disabled.

    Does your web interface look like the link below?

    http://event.asus.com/2012/nw/dummy_ui/en/Advanced_WAdvanced_Content.html

    If so, enable the "Wireless Multicast Forwarding" option.  I've never dealt with any Asus products but on some wireless APs you have to enable the transmission/receiving of multicast traffic for wireless clients.  I think that's probably this option on your device.

    That looks pretty close to my Asus GUI setup, and I will double check this option, but remember my Asus is in AP only mode, which I think severely limits the options available.  But, this seems very promising and I will follow up tonight!  (also research what Multicast DNS is:))


  • LAYER 8 Global Moderator

    "but remember my Asus is in AP only mode, which I think severely limits the options available."

    And that is a AP/Wireless feature.. Not an connection to internet/rouer feature ;)  Its says hey do not forward multicast traffic between wireless clients or wired wireless clients.  In a netshell do not send multicast over wireless.

    Wireless multicast forwarding
    :  Select Enable  to allow the wireless router to forward multicast traffic to other wireless devices that support multicast. Select Disable  to prevent the router from forwarding multicast transmissions.

    You could also have an issue with the transmission rate of multicast
    Multicast rate (Mbps) :  Select the multicast transmission rate or click Disable to switch off simultaneous single transmission

    You could also have issues with isolation mode..
    Set AP isolated :  The Set AP isolated item prevents wireless devices on your network from communicating with each other. This feature is useful if many guests frequently join or
    leave your network. Select Yes  to enable this feature or select No  to disable.

    Some devices when isolation is on even prevent wireless from initiating connection from wireless to wired..

    When in AP mode, all of the features of "wireless" would and should still be valid features to enable or disable.  When you put the device or use it AP mode the only features that are now not used would be firewall between internet and lan, or natting features - and your normally not going to want the AP to be running dhcp, or dns, etc..  But all of the "wireless" features would still be in play because your using the wireless!!!



  • @johnpoz Great! Thanks for all that information.  I'll check all this tonight and report back.  I'm cautiously optimistic ;D



  • https://www.dropbox.com/s/ce9ceryslykmnkx/Screen%20Shot%202017-01-05%20at%205.47.30%20PM.png?dl=0

    • There is an option for Multicast Rate(Mbps) which is set to Auto.  I wouldn't know what else to set it to.  The other options are a bunch of seemingly random numbers prefixed with ODFM

    • There is an option for "Set AP Isolated" but "No" is already selected.

    • There is also an option for "Enable IGMP Snooping" which I don't see in the screenshot you shared but was something you first suggested, so I enabled it on both radio frequencies…



  • @RickyBaker:

    ahhh bummer. No  Enable Wirless Multicasting option.  See here https://www.dropbox.com/s/ce9ceryslykmnkx/Screen%20Shot%202017-01-05%20at%205.47.30%20PM.png?dl=0

    I thought that idea had so much promise!  Thanks for the screenshot @jamesonp that was very useful in making sure I just wasn't missing it.

    @RickyBaker:

    FYI, for good measure I disabled IGMP snooping to see if the auto-detection wizard would still find my running host and it appears to still be able to detect the running host.  Still, thanks again to both of you:)



  • @jamesonp:

    The reason that's occurring is that the wireless AP keeps a table of multicast devices/MAC addresses from when you enabled it previously.  Just because you disabled it doesn't mean that it cleared that table.  I bet if you manually cleared that table or restarted the AP, the auto detection wizard wouldn't display anything again.

    The ability to locate your Kodi device would be directly related to you enabling IGMP snooping.

    Interesting.  So you're saying it wasn't a port collision?  Why did it change when I changed the port?  To restate what I witnessed:

    • I enabled IGMP snooping

    • Checked Yatse Auto-detection Wizard and it shows 2 clients: my Kodi client by name but with a question mark in the ip address.  And a phantom client with no name or ip address.

    • Change the port in the Kodi interface from 8080 to 1000

    • Checked Yatse and it shows 1 client: my Kodi client with the correct namd AND IP address

    • I DISabled IGMP snooping

    • Checked Yatse and it shows 1 client: my Kodi client with the correct namd AND IP address

    I assume you understood this timeline, just wanted to make sure.  I'll try to manually restart the AP tonight to test…I'm curious now...



  • I rebooted the AP and "forgot" my Kodi client in the Yatse app and it reappeared when I ran the wizard despite not enabling IGMP snooping.  Just reporting back, still happy everything works:)


  • LAYER 8 Global Moderator

    "@johnpoz (repeatably:)) said, it didn't have anything to do with multicasting"

    I never said that once - what I said repeatedly is that it has nothing to do with PFSENSE.. Since pfsense has ZERO to do with clients talking to each other on the same network.. Pfsense is a GATEWAY!!  Of that network if clients want broadcast or multicast pfsense gives 2 shits ;)  And has nothing to do with that..


Log in to reply