PfSense e Technicolor TG788vn v2 (Tiscali VDSL2)



  • Ciao,
    ho sottoscritto un abbonamento con Tiscali, VDSL2 100/20 + VOIP.
    Tiscali fornisce gratuitamente il router/modem Technicolor TG788vn v2 che gestisce pure la fonia, l'unità non è configurabile (ma facilmente sbloccabile).
    Io comunque gestirò la parte dati con un Draytek V130 in bridge con pfSense.
    Mi domandavo se qualcuno avesse mai collegato il Technicolor come semplice client a pfSense in maniera da usarlo come semplice centralino VOIP.
    Tiscali usa la VID 935 per la fonia e 835 per i dati, i dati di accesso del VOIP non sono disponibili.
    Premetto che sono una schiappa con le VLAN (sto studiando), ma se qualcuno ha risolto sarei grato di provare anche io.
    Grazie



  • Interessa molto anche a me. Anch'io ho una 100/20 con Tiscali ed il Techincolor.
    Un mio cliente, ha recentemente dismesso un Firebox X500e che ho prontamente flashato con pfsense 2.3 nano. Ho provveduto anche a far funzionare il display ma ancora non sono riuscito a far funzionare i led delle NIC…vabbè, ci ho perso poco tempo, poi vedrò.

    Mi interessava se possibile, configurare il Technicolor in bridge per poi far lavorare pfsense. Riguardo al voip, attualmente ho un PBX asterisk che gira su un hardware "rimediato" ma va che una meraviglia con fasci eutelia. So che Tiscali non fornice i dati per i trunk, ma tramite un semplice gateway, domando, forse è possibile. Vorrei sapere infine, se sbloccando il technicolor, la linea voip sarà comunque utilizzabile?

    Ciao



  • Dopo alcune ricerche, ho trovato qualche soluzione (non testata perché non ho ancora la VDSL attiva) per quanto riguarda VOIP, non mi interessa usare il Technicolor in bridge, prefererisco il Vigor 130.
    Una volta ottenuti i privilegi di admin, sbloccato telnet, é possibile configurare una delle porte lan del tecnicolor come trunk:

    eth bridge vlan ifadd brname=bridge name=Voice intf=ethport1 untagged=disabled
    

    Ora il tizio che è riuscito a far andare il technicor come semplice client voip, ha un router openWrt e ha configurato una porta in bridge con la wan…credo:

    config interface 'voice_tiscali'
    option type 'bridge'
    option proto 'none'
    option ifname 'eth0.935 ptm0.935' 
    
    config switch_vlan
    option device 'switch0'
    option vlan '2'
    option ports '0t 1t 2t 4t 6t'
    option vid '935'
    

    Questo è il technicolor quando funge da Modem/Router/Voip (prima di metterlo dietro pfSense o altro router):

    ip iplist expand=enabled proto=ipv4
    Flags legend: [P]referred  primar[Y]     [R]oute    [H]ost route  d[E]precated  [i]nvalid
                  [T]entative  d[u]plicated  [A]nycast  auto[C]onf    [D]ynamic     [O]perational
    Prefix             Interface        Type           Flags              Remote IP Origin
    ------             ---------        ----           -----              --------- ------
    10.138.X.X/22      Voice            Ethernet       ...H.......O                 admin
    192.168.X.X/24     LocalNetwork     Ethernet       PYRH.......O                 admin
    217.133.X.X/32     Internet-vdsl    Serial         ..RH......DO   213.205.X.X    ppp
    127.0.0.1/32       loop             Internal       ...H......DO                 k
    
    Internet su VLAN 835 e Voice su 935.
    
    Qui mi fermo, appena mi attivano e metto le mani sul technicolor farò delle prove ma consigli dai più esperti sono graditi.
    Io vorrei evitare il brigde, evitare di dare ip pubblico al tecnicolor, vorrei gestire tutto con NAT e Regole firewall.[/u][/i]
    


  • Ciao, anche io sono nella tua situazione.
    Qualcuno è riuscito ad estrapolare i parametri voip? Ho letto che con Tim e Infostrada ci sono riusciti



  • @thorpe:

    Ciao, anche io sono nella tua situazione.
    Qualcuno è riuscito ad estrapolare i parametri voip? Ho letto che con Tim e Infostrada ci sono riusciti

    Io non voglio estrapolare i parametri, alcuni ci sono riusciti (intendo decifrare proprio user e pwd) ma non funzionano inserendoli su un altro apparato (trovi tutto su questo interminabile thread http://www.hwupgrade.it/forum/showthread.php?t=2724487&page=650)

    Il mio fine è quello di usare il Technicolor come client VOIP e definire la metodologia più corretta di collegamento, cosa che attualmente nei forum non è stata ancora fatta. Le soluzioni DMZ, bridge WAN-LAN_VOIP non le trovo particolarmente corrette, preferendo invece una soluzione di routing con regole Firewall e NAT (se fattibili).

    Tuttal mia rete (NAS,TV,HTPC, AP WiFI, IP CAM etc etc) confluirà su uno Switch Cisco SG350 che segmenterà la rete taggandola opportunamente. Il Cisco sarà collegato poi al pfSense che si occuperà sostanzialmente di Routing/NAT/Firewall e PPPoE.



  • @Wolf666:

    Dopo alcune ricerche, ho trovato qualche soluzione (non testata perché non ho ancora la VDSL attiva) per quanto riguarda VOIP, non mi interessa usare il Technicolor in bridge, prefererisco il Vigor 130.
    Una volta ottenuti i privilegi di admin, sbloccato telnet, é possibile configurare una delle porte lan del tecnicolor come trunk:

    eth bridge vlan ifadd brname=bridge name=Voice intf=ethport1 untagged=disabled
    

    Ora il tizio che è riuscito a far andare il technicor come semplice client voip, ha un router openWrt e ha configurato una porta in bridge con la wan…credo:

    config interface 'voice_tiscali'
    option type 'bridge'
    option proto 'none'
    option ifname 'eth0.935 ptm0.935' 
    
    config switch_vlan
    option device 'switch0'
    option vlan '2'
    option ports '0t 1t 2t 4t 6t'
    option vid '935'
    

    Questo è il technicolor quando funge da Modem/Router/Voip (prima di metterlo dietro pfSense o altro router):

    ip iplist expand=enabled proto=ipv4
    Flags legend: [P]referred  primar[Y]     [R]oute    [H]ost route  d[E]precated  [i]nvalid
                  [T]entative  d[u]plicated  [A]nycast  auto[C]onf    [D]ynamic     [O]perational
    Prefix             Interface        Type           Flags              Remote IP Origin
    ------             ---------        ----           -----              --------- ------
    10.138.X.X/22      Voice            Ethernet       ...H.......O                 admin
    192.168.X.X/24     LocalNetwork     Ethernet       PYRH.......O                 admin
    217.133.X.X/32     Internet-vdsl    Serial         ..RH......DO   213.205.X.X    ppp
    127.0.0.1/32       loop             Internal       ...H......DO                 k
    
    Internet su VLAN 835 e Voice su 935.
    
    Qui mi fermo, appena mi attivano e metto le mani sul technicolor farò delle prove ma consigli dai più esperti sono graditi.
    Io vorrei evitare il brigde, evitare di dare ip pubblico al tecnicolor, vorrei gestire tutto con NAT e Regole firewall.
    
    Ciao Wolf, sei poi riuscito a far funzionare il tutto?
    
    Io dopo ripetuti tentativi, non riesco a sbloccare il technicolor, dopo il reset e tenendolo scollegato da internet, resta morto come un pezzo di ferro. Ho atteso anche alcune ore, ma niente.
    
    Nel frattempo, sto usando uno zyxel 3300 in pppoe e funziona egregiamente, ma ovviamente non posso usare il voip. Mi è appena arrivato un piccolo gateway con porta FXO da collegare al mio centralino asterisk ed al technicolor, ma prima vorrei sapere come fare per mettere il technicolor in bridge per gestire il tutto da pfsense.
    
    Hai per caso dritte in merito?
    
    Ciao[/u][/i]
    


  • Dovrebbero attivarmi la VDSL il 6 marzo, ho già il technicoso, aggiornerò il thread appena possibile.



  • Dunque, seppur sia riuscito a avere i privilegi di SuperUser sul Technicolor e dunque lavorare sia sul file di configurazione che via telnet, la parte Voip non va.
    Ho settato la porta Ethernet 1 come trunk collegata alla porta trunk del mio Cisco SG350 che a sua volta è collegato alla trunk di psSense.
    Sul technicolor le due reti LAN 192.168.1.0/24 e VOIP 10.134.16.0/22 sono raggiungibili e pingabili da pfSense.
    La LAN correttamente aggiorna l'orario e comunica con internet.
    La VOIP cerca di risolvere l'indirizzo del registar usando il DNS resolver di pfSense (192.168.1.1) ma poi nulla….
    Temo che ci sia un problema di DNS sul technicolor che non riesco a risolvere via telnet o file di configurazione.
    Continuerò gli esperimenti.....



  • Giusto per chiudere la questione.
    Non c'è verso di far funzionare il Technicolor come semplice PBX e dunque sono dovuto ricorrere ai metodi forti, vale a dire ricavare la PWD del VOIP Tiscali.
    Fatto questo, ho semplicemente riconfigurato un banale PBX (Gigaset A540-IP) collegandolo alla mia rete (su una VLAN dedicata) e tutto funziona egregiamente, senza usare apparati vecchi, poco performanti e sostanzialmente poco sicuri (il technicolor usato come modem/router principale  è un portone aperto al mondo).
    Concludo che è ignobile non fornire le credenziali VOIP agli utenti ed impedir loro di usare i propri apparati. E' comunque in discussione, a livello UE, una legge per liberalizzare l'uso dell'hardware.



  • Salve a tutti,
    sono nuovo del forum ed ero interessato alla questione del technicolor di Tiscali.
    Io ho attivato una fibra 100/20 con il modem in comodato d' uso, ed utilizzo un fritzbox 7272 con un trunk voip clouditalia.
    Da quello che vedo si comporta molto strano, a volte và e a volte no, ossia molto spesso cercando di ricevere telefonate in ingresso, ottengo il tono di occupato o di non registrato.
    Spostando tutto su un ' ADSL tradizionale, e non cambiando nulla nella configurazione, funziona tutto.
    Avete avuto esperienze in merito?
    Grazie e buona serata