Unexpected behavior:Ubuntu-Mate 16.04.1 and DHCP/DNS



  • Hi all,
    I'm confused and befuddled about the situation on one of my PCs on which I installed Ubuntu-Mate 16.04.1 yesterday. It cannot resolve names on my LAN.

    I spent more time than I should have trying to figure out what I had done wrong with a new ( <q week)="" pfsense="" install="" until="" i="" realized="" the="" issue="" was="" on="" pc="" end="" of="" connection.="" it="" turns="" out="" that="" etc="" resolv.conf="" is="" pointing="" to="" name="" servers="" have="" configured="" in="" pfsense.="" all="" my="" other="" pcs="" (including="" others="" also="" run="" ubuntu="" 14.04)="" are="" either="" localhost="" (127.0.0.1="" -="" presume="" they="" forwarding="" firewall)="" or="" directly="" firewall.="" frankly="" i'm="" astounded="" none="" these="" seems="" an="" identical="" dns="" configuration.<br="">I cannot see any way that the PC in question is getting that DNS entry except through DHCP. I have no idea if that is a result of configuration on pfSense or on the PC itself (or some combination of the two.)

    Any help resolving this is most welcome.

    The configuration is as follows:

    hbarta@olive:~$ inxi -S
    System:    Host: olive Kernel: 4.4.0-57-generic x86_64 (64 bit) Desktop: MATE 1.12.1
               Distro: Ubuntu 16.04 xenial
    hbarta@olive:~$ cat /etc/resolv.conf
    # Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
    #     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
    nameserver 8.8.8.8
    nameserver 8.8.4.4
    nameserver 2001:4860:4860::8888
    search localdomain
    hbarta@olive:~$ cat /etc/nsswitch.conf
    # /etc/nsswitch.conf
    #
    # Example configuration of GNU Name Service Switch functionality.
    # If you have the `glibc-doc-reference' and `info' packages installed, try:
    # `info libc "Name Service Switch"' for information about this file.
    
    passwd:         compat
    group:          compat
    shadow:         compat
    gshadow:        files
    
    hosts:          files mdns4_minimal [NOTFOUND=return] dns
    networks:       files
    
    protocols:      db files
    services:       db files
    ethers:         db files
    rpc:            db files
    
    netgroup:       nis
    hbarta@olive:~$ 
    
    

    On one PC - an older install on a laptop - I see

    hbarta@yggdrasil:~$ inxi -S
    System:    Host: yggdrasil Kernel: 4.4.0-47-generic x86_64 (64 bit) Console: tty 1
               Distro: Ubuntu 16.04 xenial
    hbarta@yggdrasil:~$ cat /etc/resolv.conf
    # Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
    #     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
    nameserver 127.0.1.1
    search localdomain
    hbarta@yggdrasil:~$ cat /etc/nsswitch.conf 
    # /etc/nsswitch.conf
    #
    # Example configuration of GNU Name Service Switch functionality.
    # If you have the `glibc-doc-reference' and `info' packages installed, try:
    # `info libc "Name Service Switch"' for information about this file.
    
    passwd:         compat
    group:          compat
    shadow:         compat
    gshadow:        files
    
    hosts:          files mdns4_minimal [NOTFOUND=return] dns
    networks:       files
    
    protocols:      db files
    services:       db files
    ethers:         db files
    rpc:            db files
    
    netgroup:       nis
    hbarta@yggdrasil:~$ 
    
    

    I have four DNS servers configured in pfSense - 2 x IPV4 and 2 x IPV6 for Google. Boxes for DNS Server Override and Disable DNS Forwarder are both unchecked.

    I have just upgraded to 2.3.2-RELEASE-p1 (AKA 2.3.2_1)

    Any suggestions on how to resolve this (pun intended - I kill myself! ;) ) are most appreciated!

    Edit: After I solve this, I need to figure out how this host gets to external name servers. I thought I had that blocked. :-/

    Edit.2 Additional information. This post (http://askubuntu.com/questions/837982/how-to-configure-local-dns-lookup-in-ubuntu-16-10/838395#838395) ends with a suggestion:

    sudo apt purge libnss-resolve
    sudo apt install libnss-resolve
    

    I tried that and it fixed the problem! :D
    I rebooted and the problem was back! :(

    I'm starting to think this is more likely an Ubuntu issue.</q>


  • Banned

    Yeah, bingo, this forum is not for Ubuntu.


Log in to reply