IGMP, DNLA, Chromecast - different networks.



  • Hi.

    On my pfSense box I have the following:

    Port 1 WAN - PPPOE
    Port 2 LAN - 192.168.1.x range
    Port 3 Wireless AP - 10.10.1.x range

    I have a Chromecast connecting to the Wireless AP and gets a 10.10.1.x IP Address.
    (All wireless devices have static allocations in the DHCP Server)
    My PC has a 192.168.1.x LAN IP Address.

    On my LAN I have 2 IP PBX's (testing etc) that use multicast. The LAN switch is doing Port based VLAN's and that works fine.
    It stops the multicast from PBX A getting to PBX B etc.

    I've now noticed my smartTV (wireless) can't see my NAS (LAN) and I can't use my Chromecast from my PC, so I decided to add the IGMP Proxy.

    Upstream WIFI set with 239.255.255.250 & 192.168.1.100 (NAS)
    Downstream left open.

    I added a rule to my WIFI Interface (OPT1) to allow 239.255.255.250

    Now my TV can see my NAS, but the system logs are showing constant messages of

    The origin for route 224.0.1.51 changed from 192.168.1.101 to 192.168.1.102 (PBX A)
    The origin for route 224.0.1.51 changed from 192.168.1.102 to 192.168.1.101 (PBX B)

    Is it possible to stop these messages ?

    Also what do I need to add to allow the PC to find and then stream to the Chromecast ?

    Thanks


  • Banned

    Pretty sure this worked with about zero work required after installing Avahi.



  • Hi
    I've installed Avahi and enabled it, but it doesn't seem to have helped.

    How do I configure it?
    Thanks



  • Can anyone advise what I add to the domain field ?

    My pfSense is called 'pfSense.localdomain'.. do I add my IP ranges ?
    Thanks


  • Banned

    What domain field where?



  • @TomT:

    Can anyone advise what I add to the domain field ?

    My pfSense is called 'pfSense.localdomain'.. do I add my IP ranges ?
    Thanks

    Just leave it as local.

    I've found adding a blanket IPv4 IGMP allow all rule under floating to all your local interfaces (VLANs included) allowed traffic to correctly pass.  Make sure you check the "allow packets with IP options" option under advanced options in the IGMP rule you add.

    Also make sure your access points allow multicast traffic to pass.



  • Thanks for the advice I plan to try this tomorrow.

    I don't want LAN multicast from 192.168.1.101 (PBX A) or 192.168.1.102 (PBX B) to pass through the firewall.

    Can I just add a block rules for those two IP addresses on IGMP on the LAN ?

    I've also found today my PC can't print or scan to my printer on the Wireless AP. A quick look at the logs seems to suggest multicast is used to find it. If I move it into my LAN then it works. I'm hoping setting this up will allow that to work as well when it's on the Wireless network..

    Thanks



  • @TomT:

    I've also found today my PC can't print or scan to my printer on the Wireless AP. … multicast is used to find it.

    Old school is setting up the printer and scanner by hand, using their IP addresses in the foreign subnet. Still know how to do that?



  • The printer is a Dell and from my LAN I can ping it and access it's web interface.

    I reconfigured it manually, but seemed unable to print or scan. Windows 10 complained there was no scanner available.

    I tried running the Dell installer and that worked fine until it got to network settings. It seemed to get upset as the printer was on a different IP range to the PC.

    I connected the printer to the LAN and set it up via the installer and it worked fine. Moved it back to the wireless and tried to change the IP address the driver was using but it's configured for WDS so no address to change.

    Wireless clients can print and scan, it just the LAN PC that can't.

    I plan to try Avahi again in the morning.. any other suggestions are welcome.

    Thanks



  • I decided to test this tonight.

    Installed Avahi, left it on it's default settings.
    Added a single Floating rule as per the screen shot.

    The printer will add and work as a printer, but nothing regarding the scanner. Windows doesn't seem to detect it.
    I'll try in the morning connecting the printer to the LAN and manually adding a new TCP/IP Port and see if Windows is happy with that. Then move the printer back to the wireless network and see what happens when I update the IP Address.

    I'm still unable to see my Chromecast from the LAN and the Smart TV (wireless) can't see the NAS (LAN)

    So I've not got something set up right.

    Any other ideas ?
    thanks



Log in to reply