Zabbix proxy on pfsense



  • Hi Team,

    I have pfsense installed all up to date. I have zabbix proxy and agent installed , the TLS package and was working fine. Now all of sudden I get this error :

    80822:20170109:123436.959 [Z3005] query failed: [0] database disk image is malformed [insert into proxy_history (itemid,clock,ns,value) values (26676,1483965276,44232840,'1658526404');
    ]

    I have tried to remove and reinstalled but still no joy.

    Could anyone assist please?

    Rajbps



  • Just a wild guess: your disk is not full, is it?



  • that`s the output of df -h

    /root: df -h
    Filesystem        Size    Used  Avail  Capacity  Mounted on
    /dev/ad4s1a    59G    3.7G    50G    7%        /
    devfs                1.0K    1.0K      0B    100%      /dev
    /dev/md0          3.4M  132K    3.0M    4%      /var/run
    devfs                1.0K    1.0K      0B    100%      /var/dhcpd/dev



  • Ok sorted the issue myself. Here is the solution for anyone that might have the same issue.
    Go to
    /var/db/zabbix-proxy-lts
    there should be a db file there called : proxy.db

    Go to the gui and disable zabbix proxy, then rename that db file to proxy.db.old.

    Now enable zabbix proxy again. This will recreate a new db file without the corruption.

    This worked for me at least.

    Rajbps



  • I was going to reply with that. Glad you found it.


Log in to reply