Ebox (or EPATec) series 4852, 4853, 4863 Realtek 8100B - *** RESOLVED



  • Good evening,

    I have a ebox 4863 (these are also sold as EPATec out of spain) http://www.compactpc.com.tw/ebox-4852.htm

    they evidently have 2 x Realtek 8100B Network ports.

    the 1st port works fine with PFSense, however the 2nd port won't work (makes it very hard to work as a firewall).

    PFSense finds both ports and says they are both up, but no data flow. with port one as Lan & port two as Wan the Lan works fine, when you set Wan as port one and Lan on port two the wan works fine but no Lan.

    found lots of googles that say Realtek cause problems with pfsense, but real strange one works fine, the other doesn't.

    the spannish version of these offer it with pfsense http://store.epatec.net/es/pdf_datasheet.php?products_id=53 so it seems there is a solution.

    Any help would be greatly appreciated.



  • Please give more details on why you say port 2 "won't work". For example: I did … and I expected to see ... but I saw ...

    What version of pfSense have you installed? The 1.2.1 BETA or RC builds might better than 1.2 because the device drivers are more up to date.

    What do you have connected to the pfSense box?



  • Thanks for your response wallabybob

    sorry firstly should have mentioned I first tried the 1.2 release which I am running on a couple of other pcs with intel network cards with no problems. I also tried the pfSense-20080913-0347.iso.gz which seems to be the latest snapshot, it did exactly the same (i understand the latest snapshot runs the latest BSD).

    I have tried it on two seperate boxes, box seem to do the same thing.

    I just have the box connected to a network switch, when I use port 1 as the Lan it works fine, if I swap ports the port 2 as the LAN doesn't work. Its port led shows as connected, the status shows as up in the pfsense console, when you ping from inside the box to the lan using port 2 the data light flashes on the port as if data is going out, if you ping the lan address the data let flashes, so it appears the hardware is all working just data doesn't get through to bsd

    Had similiar problem when I set up one of my pcs (intel motherboard with NIC onboard) and using a realtek card as the 2nd port, fixed it by swapping the realtek card for an intel card and everything was fine. Unfortuantly can't do that with this box. Strange thing is both Lan ports are Realtek 8100B and one works, one doesn't.

    ran ifconfig from the shell and both ports show as all operational in BSD everthing says both ports are working the same, just no data goes anywhere when using the 2nd port.  I also note that BSD seems to identify both NIC as Realtek 8139's. I am at a real loss, as far as I can see BSD sets up both cards the same yet one won't work.

    Any help to identify the cause, or hints as to work out what is going on would be appreciated.



  • Suggest you work with one configuration: port 1 (working port) as LAN, port 2 as WAN. Then you can look at the pfSense box through the web GUI.

    Now, what do you do to test that configuration?

    How did you decide "port 2" was broken (e.g. I did … and I expected to see ... but instead I saw ... - you replace the  "…" ).



  • Thanks for your help,

    turns out it appears to have been a hardware issue all along with the 2nd Nic port on 2 x units, managed to get hold of a third box this morning and it works fine.

    So looks like it is nothing to do with bsd

    thanks again for your help.

    will report back on how successful these are, small box the size of a full size cd rom with 2 x nic ports 1.2ghz processor & 1gb ram, no fans.


Locked