(Resolvido) Como liberar atualizacoes para meu servidor linux


  • Ola, bom dia!

    Sou analista de sistemas com pouco conhecimento em suporte, mas estou montado um firewall usando o PFSense 2.3.2.

    Agora, estou reativando um servidor de aplicacao que tinha antes do PFSense para instalar o PostgreSql. O problema eh que nao consigo mais fazer atualizacoes nele. Veja:

    _[root@rceaplic Cavalcante]# cat /etc/resolv.conf

    Generated by NetworkManager

    No nameservers found; try putting DNS servers into your

    ifcfg files in /etc/sysconfig/network-scripts like so:

    DNS1=xxx.xxx.xxx.xxx

    DNS2=xxx.xxx.xxx.xxx

    DOMAIN=lab.foo.com bar.foo.com

    nameserver 192.168.180.20
    nameserver 8.8.8.8
    nameserver 8.8.4.4

    [root@rceaplic Cavalcante]# service iptables stop
    iptables: Configurando chains para a política ACCEPT: filte[  OK  ]
    iptables: Liberando regras do firewall:                    [  OK  ]
    iptables: Descarregando módulos:                          [  OK  ]

    [root@rceaplic Cavalcante]# yum -y update
    Plugins carregados: fastestmirror, refresh-packagekit, security
    Configurando o processo de atualização
    Loading mirror speeds from cached hostfile
    Could not get metalink https://mirrors.fedoraproject.org/metalink?repo=epel-6&arch=x86_64 error was
    14: PYCURL ERROR 7 - "Failed to connect to 2610:28:3090:3001:dead:beef:cafe:fed3: A rede está fora de alcance"

    Como voce viu… parei inclusive o firewall do servidor. Tambem, nao consigo ver nenhuma mensagem de bloqueio no PFSense. Por favor, o que tenho que liberar para que funcione.

    Muito obrigado,
    Cavalcante.


  • Nos fale como o seu proxy está trabalhando hoje e como seu cenário é na sua rede, para podermos entendermos e nos fale sobre esse seu servidor linux.


  • Vamos la…

    Segue em anexo um esboco da topologia da minha rede.

    Hoje nao trabalho com proxy, pois estava muito lento, entao parei.

    Tinha preparado o servidor linux CentOS para publicar um sistema Java de uso interno usando Apache e Tomcat, mas mudei de foco na epoca. Agora, estou voltando para instalar o PostgreSQL e tentar fazer o servidor funcionar.

    Muito obrigado,
    Cavalcante.



  • No caso esse teu roteador da vivo ele chegar em uma outra placa de rede na tua rede?
    Faz assim, cria uma regra liberando tudo para esse IP 192.168.180.15, faça ele não passar pelo o teu proxy
    P.S.: qual programa tu utilizou para fazer esse esboço ?


  • Bom… o meu firewall possui 4 placas de rede, conforme imagem. A primeira eu ligo no roteador da Vivo; a segunda no roteador da Net; terceira no switch da minha rede principal (DHCP pelo Windows Server); e a quarta no switch da rede wifi (DHCP pelo PFSense). Infelizmente, nao entendi a pergunta sobre o roteador da Vivo.

    Fiz uma regra liberando tudo para o IP 192.168.180.15 e continua igualzinho. Veja imagem em anexo.

    Para conhecimento, utilizei o programa Dia para fazer o esboco.

    Abraco e obrigado!



  • Failed to connect to 2610:28:3090:3001:dead:beef:cafe:fed3: A rede está fora de alcance"
    "Failed to connect to 2001:12f0:6c0:642::a198: A rede está fora de alcance"

    Acredito que não seja problema do pfsense e sim do teu centOS. Ele esta requisitando um endereço IPV6. Tu tem ipv6 configurado em tua rede?

    Dá uma olhada no link abaixo.
    yum ipv6 problem!


  • @empbilly:

    Failed to connect to 2610:28:3090:3001:dead:beef:cafe:fed3: A rede está fora de alcance"
    "Failed to connect to 2001:12f0:6c0:642::a198: A rede está fora de alcance"

    Acredito que não seja problema do pfsense e sim do teu centOS. Ele esta requisitando um endereço IPV6. Tu tem ipv6 configurado em tua rede?

    Dá uma olhada no link abaixo.
    yum ipv6 problem!

    Prezados, realmente o meu problema estava apenas relacionado com o CentOS e suas configuracoes. Apos a entrada do meu firewall, minha rede sofreu algumas alteracoes, inclusive no endereco do meu gateway. Isso era o problema… antigamente, ele respondia em outro IP.

    Assim, bastou trocar o ip do gateway no arquivo /etc/sysconfig/network para que voltasse a funcionar. Ainda ocorre muito erro "404 not found", mas acredito que sejam repositorios antigos. Sera?!?

    Muito obrigado,
    Cavalcante.


  • Assim, bastou trocar o ip do gateway no arquivo /etc/sysconfig/network para que voltasse a funcionar. Ainda ocorre muito erro "404 not found", mas acredito que sejam repositorios antigos. Sera?!?

    Com certeza deve ser isso! Talvez tu tenha que atualizar teu repositório e sistema.


  • @empbilly:

    Assim, bastou trocar o ip do gateway no arquivo /etc/sysconfig/network para que voltasse a funcionar. Ainda ocorre muito erro "404 not found", mas acredito que sejam repositorios antigos. Sera?!?

    Com certeza deve ser isso! Talvez tu tenha que atualizar teu repositório e sistema.

    Massa e obrigado!!!