[SOLVED, I think…?] USB keeps unmounting, and pfSense crashes.



  • Hey all, I'm hoping someone can point me in the right direction.  I finished building my machine last night and got it up and running with ease.  Problem is, after a few minutes of running, I'll see one of these two errors, which seem to both be related to not being able to read the USB drive:

    (something about my SanDisk USB drive) … detached ... periph destroyed ...
    or
    ccb request completed with an error (I see this over and over once it starts)

    Sorry for the vagueness on these two errors, I'm at work so I don't have access to pfSense right now.  I'll fill this post in with more details when I get home.

    I did some googling and searching on this forum and tried a couple things.  First I tried a different USB drive, with the same result.  I also tested all the other USB ports (including the front case ports from the mobo USB3.0 header), also with the same result.

    The only thing I can think to try is to re-download the image and try again from scratch.  Maybe the download was bad?  I didn't verify it before imaging it to the flash drive.

    Other than that, is there anything else y'all can think of?  Thanks again!

    -Dave



  • Well, I'm not sure I figured it out, but I'm up and running, nonetheless.

    To get around the problem, I decided to perform a full install on a PNY SSD that Best Buy had on sale today.  I figured, if it was a problem with the USB interface, or pfSense's mounting/unmounting of the USB drive, then this would get around it.

    I was wrong.

    Here are all the different issues I saw in total, starting with trying to run NanoBSD.

    When trying to run NanoBSD:
    I couldn't get the BIOS to boot the USB when using:
      Windows, extract with winRAR, burn with disk imager
      Windows, extract with winRAR, burn with rufus
      Windows, extract with 7zip, burn with disk imager
      Windows, extract with 7zip, burn with rufus

    I DID get the BIOS to boot the USB, using OSX, with the terminal command 'gzcat pfSense-blahblah-image-name.iso.gz | sudo dd of=/dev/rdisk3 bs=1m'.  However, this is where I ran into the issues detailed in the original post.

    Fast forward to this evening, when trying to run a full install:
    Again, I couldn't get the BIOS to boot the USB with any of the combinations above, this time INCLUDING OSX.  Frustration!!
    I decided to go 'old school' and burn the ISO to a DVD.  STILL wouldn't boot!  At that point I determined it had to be something funky with the BIOS settings, because I noticed these devices weren't even showing up under the BOOT tab of the BIOS settings, like I'm used to seeing.

    I started playing around with BIOS settings, I found, under the BOOT tab, a 'Compatibility Support Mode (CSM)' that was disabled.  I enabled it, and I set all newly displayed options to "Legacy Only".  Save settings and reboot into BIOS.  EUREKA, the boot tab shows both the DVD drive and the USB drive as bootable devices!  I proceeded with the USB drive, installed pfSense to my SSD, and now I'm up and running.  Fingers crossed, I haven't seen any issues.

    The reason I stated that I'm "not sure if I figured it out", is because after finding that BIOS setting, I never tried to run a NanoBSD setup to see if my original issues were gone.  The only conclusion I can come to is:
    1.  BIOS settings were incorrect, causing it to not recognize boot devices, when that boot device was created with Windows/image writer or Windows/rufus.
    2.  Somehow OSX wrote the NanoBSD image to the USB drive in such a way that the BIOS recognized it, and booted, but pfSense didn't like it for some reason, causing the issues in the original post.
    3.  Once I changed the BIOS settings to recognize the boot devices, I can only assume that running NanoBSD using a USB drive written using rufus, etc. would have worked just fine, and I wouldn't have needed to buy the SSD in the first place.

    As it is, I'm completely happy running a full install, and I hope that all the "pfSense killing SSD" gloom and doom posts are blown out of proportion considering today's hardware being vastly superior to legacy SSDs.

    Sorry for the long-winded post, but if anyone else runs into these issues, I wanted to document my experience, and how I got going, before the information falls out of my brain (ie, tomorrow).


Log in to reply