Can not access cups interface after switching to pfsense


  • Hi, so I have been setting up pfsense  for the past few weeks tweaking and working out bugs for my network. I just noticed I can not access my 
    cups interface anymore. I think it is related to squid. I tried my other linux box and it just hangs. I have tried to look at the firewall logs but I dont see anything.

    Here are my running services
    –pfSense 2.3.2-RELEASE-p1
    ----squid (transparent mode)
    ----squid guard
    ----pfblocker
    ----snort
    ----openvpn
    ----dynamic dns
    ----dns resolver

    Here is the error I get

    ERROR

    The requested URL could not be retrieved

    The following error was encountered while trying to retrieve the URL: http://localhost:631/

    Connection to ::1 failed.

    The system returned: (60) Operation timed out

    The remote host or network may be down. Please try the request again.

    Your cache administrator is admin@localhost.


  • Are you using IPv6 on your network?


  • Well I figured out the problem (with one computer) for some reason on both computers cups-browsed.services was inactive/dead I restarted the services which now say active but only one computer can access the cups menu at this time.

    The laptop still times out. Yesterday I disabled IPV6 under "System, Advanced, Networking" on the pf Server, I do not have an ipv6 address set for my pfbox and I also disabled the IPV6 stack on the two computers in the kernel.  I really wish I could just build cups into pfsense. The printer is wireless.