Cannot Ping LAN VIP in HA Setup



  • I have setup HA according to the tutorial. CARP faiiover is perfect and syncs configuration syncs as defined. I can ping the WAN VIP and LAN VIP from the primary router/firewall. If I failover to the secondary router/firewall I can ping both LAN and WAN VIPs.

    My issue is that I cannot ping the LAN VIP from the LAN Network. This may HA not usable from the LAN. Any assistance will be greatly appreciated.

    Thanks



  • This is exactly the same problem I'm having with one of my setups, and I just posted about it as well. . .  so watching for someone with the answer.



  • Curious, though, did you add a firewall rule to allow ICMP response on that IP address?


  • LAYER 8 Netgate

    This all just works, guys. Can you "ping" the interface IP addresses? Do you even get ARP for the interface addresses and CARP VIPs from LAN hosts?

    Start at layer 1 and work your way up.

    Firewall rules, as always, determine what is allowed into an interface.



  • Yes I know it SHOULD work, and it does in many other pfSense installations that I work with.

    This one is not.

    After switching the gateway from a static IP to a CARP IP address (by changing the static to something else and then adding a CARP IP for the gateway), the protocol analyzer is showing that the router is not responding to ARP requests for the gateway CARP IP address. I'm not sure where to look for the solution to this problem.


  • LAYER 8 Netgate

    If it is not responding to ARP on a CARP VIP on that interface it is likely not actually receiving the ARP who has.

    Capture on the interface there for protocol ARP.

    Check your layer 2.



  • Yes, it's the same LAN interface. The network analyzer was indeed sniffing that port before and after the change, and then after the return back to the static configuration.

    Process:
    1. LAN configured with static IP "A" as gateway for workstations. All workstations can PING "A".

    2. Virtual IP address "B" configured on LAN interface. All workstations can PING "B".
    ^^ network analyzer confirms ARP conversation

    3. Virtual IP address "B" deleted. LAN static IP changed to "B". CARP IP "A" assigned to LAN. Only a couple of workstations (out of 100+) can ping "A". All workstations can ping "B"
    ^^ network analyzer confirms that the LAN port is only responding to 2-3 of the ARP requests for the address "A" and ignoring hundreds of others. Responding fine to ARP requests regarding "B"

    CARP addresses are working fine on the two WAN ports on the same router.

    Tomorrow I will install pfSense on a different machine and start over.



  • I have been monitoring the dialog and I have not made any progress either. I am not certain what are the issues. i have built the exact same configuration within the virtual environment and the results are identical. i am going to downgrade the image rev to a previous rev and check the status of the implementation. Will keep you posted.

    Thanks



  • Can you ping both static LAN IPs from your network?



  • Yes we can ping all interfaces (LAN, WAN and WAN Carp)



  • It sounds like we're having the same problem.
    I'm curious– are you using the Captive Portal with a MAC address pass-through list? I'm suspecting this is related, but your answer will either confirm or disprove my idea.
    Thanks



  • Sorry for reviving this thread, but it was solved?



  • My issue of the unexplained ignoring of the MAC address bypass list was solved by upgrading to a development snapshot (2.3.4 something) but in a failover to the backup router, which still had 2.3.2-Release-p1, the problem still existed, so we upgraded that to whatever snapshot was available that day. As soon as the 2.3.3 maintenance release is out we'll try that and see whether the problem comes back or not.

    The problem of CARP LAN addresses not responding to workstation ARP requests has not been solved. (Summary: we change static IP address on interface to something else, create CARP virtual IP on LAN with the original IP address, at which point workstations on the network cannot see the CARP IP address. Using a packet sniffer we observe that the router's LAN interface is not responding to ARP requests by workstations for the gateway IP address. Rebooting the router and every other device on the network, including switches and workstations, did not solve the problem.)  We will try that again after the maintenance release as well.

    thanks


Log in to reply