Prefix Delegation From address is not a valid IPv6 Netmask …



  • I have fixed IP & My Service provider granted me a IPv6 which is correctly configured.
    The IPv6 is correctly configured & I can ping the outside world
    PING6(56=40+8+8 bytes) 2a02:2788:feff:6a::8 –> 2001:4860:4860::8888
    16 bytes from 2001:4860:4860::8888, icmp_seq=0 hlim=59 time=18.113 ms
    16 bytes from 2001:4860:4860::8888, icmp_seq=1 hlim=59 time=17.897 ms

    --- 2001:4860:4860::8888 ping6 statistics ---
    2 packets transmitted, 2 packets received, 0.0% packet loss
    round-trip min/avg/max/std-dev = 17.897/18.005/18.113/0.108 ms

    LAN interface has received the following informations based on ISP proposed :
    Prefix delegation Mask : 2a02:2788:feff:1300::/64
    LANinterface has therefore been assigned the following IP : 2a02:2788:feff:1300::1

    I thought it was time to have my UBUNTU configured in IPv6.
    First going on the pfSense
    Services –> DHCPv6 Server & RA --> LAN -->DHCPv6 Server

    I completed all the informations the best I could as indicate in the attached image but I always received the following :
    The following input errors were detected:

    Prefix Delegation From address is not a valid IPv6 Netmask for 2a02:2788:feff:1300::/64
        Prefix Delegation To address is not a valid IPv6 Netmask for 2a02:2788:feff:1300::/64

    I do not understand what I am doing wrong ???

    \T,






  • Why are you trying to use a DHCP server?  It's normally not needed with IPv6.  Using SLAAC, an IPv6 address is automagically created from the prefix and NIC MAC address or a random number.  You may have one, the other or both.  The random number address will change periodically and you'll have a few deprecated addresses.



  • Because, it does not find the route …

    $ ifconfig
    eth0      Link encap:Ethernet  HWaddr 10:c3:7b:50:55:ae 
              inet addr:192.168.1.5  Bcast:192.168.1.31  Mask:255.255.255.224
              inet6 addr: fe80::12c3:7bff:fe50:55ae/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:80227219 errors:0 dropped:0 overruns:0 frame:0
              TX packets:134776834 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:25496050173 (25.4 GB)  TX bytes:189485686790 (189.4 GB)
              Interrupt:20 Memory:f7c00000-f7c20000

    lo        Link encap:Local Loopback 
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:65536  Metric:1
              RX packets:656872 errors:0 dropped:0 overruns:0 frame:0
              TX packets:656872 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0
              RX bytes:67104654 (67.1 MB)  TX bytes:67104654 (67.1 MB)

    $ traceroute6 2001:4860:4860::8888
    connect: Network is unreachable



  • Don't do Prefix Delegation Range in your DHCP-config, if you just want a DHCP-server for your LAN (Ubuntu-client).
    You probably do not want to delegate a block to the next router ? Anyway a /64 is not correct.

    But you do not need an active DHCP-server as indicated. Maybe disable the DHCP-server ?

    Then to start with IPv6, first try "Track Interface" on the LAN IPv6 configuration page.
    This will hand-out a suitable subnet value in a /64 format, with and from your ISP prefix assignment to your LAN.
    Now you can expect  RA, a route, the SLAAC method to let the LAN & Ubuntu-box make an IP.

    Next from here you could activate and  experiment with DHCP6-Server and RA configs.



  • OK
    I think I understand what I did wrong in the DHCP v6 configuration but if I try to do as you suggest, I have the following now :
    WAN interface in  IP v6 is set to 2a02:2788:feff:006a::8
    Gtw for the WAN is 2a02:2788:feff:006a::1 when this is set, I can ping the opendns/google ipv6 hosts (actually I did a traceroute6 to google DNS)!

    Now I go to the LAN configuration and choose IPv6 configuration type : Track Interface
    I need then to fill the "Track IPv6 interface" but the Drop down box is not filled.

    \T,

    ![Screenshot from 2017-01-23 01:49:03.png](/public/imported_attachments/1/Screenshot from 2017-01-23 01:49:03.png)
    ![Screenshot from 2017-01-23 01:49:03.png_thumb](/public/imported_attachments/1/Screenshot from 2017-01-23 01:49:03.png_thumb)


Log in to reply