• Bom dia Prezados.
    Estou com uma mensagem de erro estranha após atualizar o squid para a versão mais recente.
    Tenho proxy transparente + Filtro SSL.
    Em anexo a mensagem.

    Desde já agradeço qualquer ajuda.
    Lucas.


  • Isso esta acontecendo com qualquer site https?


  • Coloque o IP do site do banco em seu Bypass Proxy for These Destination IPs depois em ACL em whitelist você coloca da seguinte maneira. Você colocando com esses código, tudo que tiver na frente do nome bradesco etc será liberado pelo o seu squid. Outra coisa que recomendo é você pegar todos os host de bancos etc e criar uma aliases e colocar Bypass Proxy for These Destination IPs

    .*\.bradesco
    .*\.bb
    .*\.gov.com.br
    .*\.equatorialenergia
    .*\bradesco
    .*\.arkadin
    .*\.logmein
    .*\.bancobrasil
    .*\.caixa.\
    

  • @empbilly:

    Isso esta acontecendo com qualquer site https?

    Só em alguns, principalmente os do Governo, que não tem certificado HTTPS Homologado.


  • @danilosv.03:

    Coloque o IP do site do banco em seu Bypass Proxy for These Destination IPs depois em ACL em whitelist você coloca da seguinte maneira. Você colocando com esses código, tudo que tiver na frente do nome bradesco etc será liberado pelo o seu squid. Outra coisa que recomendo é você pegar todos os host de bancos etc e criar uma aliases e colocar Bypass Proxy for These Destination IPs

    .*\.bradesco
    .*\.bb
    .*\.gov.com.br
    .*\.equatorialenergia
    .*\bradesco
    .*\.arkadin
    .*\.logmein
    .*\.bancobrasil
    .*\.caixa.\
    

    Funcionou, obrigado !


  • Tente fechar agora o seu post e der um thanks no comentário que resolveu seu problema.


  • só pra comentar, não uso squid aqui, mas acessando diretamente vários sites de governo nos ultimos 3 dias (receita, caixa para baixar os programas de RH, etc) tenho notado que estão dando erro de certificado no navegador…

    o chrome mesmo tem alguns que só forçando o site como confiável para entrar...

    acho então que o problema não é no squid


  • O erro ta na certificação do pfsense para o site do banco. Para resolvermos isso é apenas criando regra liberando total o acesso dos respectivos sites. Resolvi aqui desta maneira.


  • Olha pessoal só complementando aqui, ontem atualizei para a versão "0.4.33" do Squid, e os problemas com certificados (Banco, Sites do Governo, Etc), aumentaram. Nâo dei pelo caso, achei que era erro de SSL mesmo. Porém hoje, alguns emails não abriram, parei pra pensar e na versão anterior do squid não tinha esse problema. Nâo estou afirmando, mais acho que tem bug aí em. Vi agora uma nova versão, "0.4.34". Amanhã irei atualizar e fazer os devidos testes.


  • Pra vcs terem ideia, por enquanto meu squid está desabilitado, pq o negócio tá feio. Toda hora é um IP pra adicionar na ALIAS de "Passar fora do proxy".


  • Nos mande todas suas configurações para olharmos. Acredito que o problema esteja acontecendo por conta de configurações


  • @danilosv.03:

    Nos mande todas suas configurações para olharmos. Acredito que o problema esteja acontecendo por conta de configurações

    Bom dia a todos amigos !
    Percebi o seguinte, após atualizar o squid, foi habilitada uma nova opção nas configurações "SSL Proxy Compatibility Mode". Estava como "Modern", alterei para "Intermediate" e até então, nos testes que fiz, está tudo ok. Obrigadoa a todos !