3g serial port conflict



  • Hello everybody,

    I've recently installed pfSense 2.3.2-p1 (AMD64) on a dedicated i5-5200 machine that has no serial port.
    I'm trying to use a Huawei E-3131 3G dongle for a failover connection. The modem only has one serial port enabled. Upon plugging it in I see the modem port as cuaU0 and can initiate a connection. However, upon restarting the machine the modem connection fails with an error message that implies that no answer was received for the AT command. To work around this I have to pull out the modem and reinsert it, after which I can acces it again using cuaU1, but only until the next reboot, when it's back tu cuaU0 again…

    Why is this happening? I believe there may be a conflict with the system console, which "hijacks" the modem port as it sees it as cuaU0, thus rendering it unusable for outgoing connections. If that is indeed so, is there any way to disable the console or otherwise persist (freeze) the port modem port designation acros reboots?

    Thank you!



  • UPDATE: I've updated /boot/loader.conf and set boot_serial="NO" and console="vidconsole" in an attempt to disable the serial console, but the problem persists…



  • you will need something like udev rules in Linux to assign a fixed port name for a USB device with the given pid, vid, serial# etc.



  • The serial console is disabled in the web configurator (and /boot/loader.conf), but ttyv0 is still activated in /etc/ttys and I cannot disable it, as the file is regenerated on boot. Is there any way to disable the console permanently and stop it from taking over the first serial port?


Log in to reply