[SOLVED] Windows 10 Network not showing NAS drive



  • This was working before. I don't know what I did that screwed this up.

    I have a 4-NIC board running pfsense 2.3.1_1. The LAN port goes through PIA openvpn, squid and squidguard. The other two ports OPT2 and OPT3 go through WAN and opendns for content filtering.

    If I connect to OPT2, everything is fine. I see my local computer and Diskstation under Network Computers, but not with LAN any more.

    I can fully access the diskstation through a browser with its IP. All the media protocols all seem to work well as well.

    Here are some of setup with the pfsense. please let me know what other information is needed.

    I have also tried to turn off vpn,squid and squidguard, and does not seem to solve the problem.

    Thanks

    I have reset the router to factory default and reconfigured basic functionality. Still, no NAS showing up in the network. I would assume this is not windows problem or the NAS', as it worked on the non-LAN interface.

    as you can see inthe last picture, once I plug in the non-LAN NIC, I can see all the computers right away including the NAS and laptop.

    I tried "NET VIEW" command. It doesn't work with LAN, but perfectly with non-LAN interface.












  • Sorry for the necro.  But, how did you solve this?  Up until now, I was under the impression this was a Windows 10 problem.  From my post here:

    https://answers.microsoft.com/en-us/windows/forum/windows_10-networking/nas-disappears-and-net-view-fails-on-non-first/6df1547d-f7fb-4b5d-b0eb-cc2d9be33bff

    With the latest build of Win10 (Version 1703, Build 15063.138), our NAS has disappeared from the Network portion of File Explorer on the last of our two computers that boot.  Trying to do "net view" from a PowerShell (Admin) window works on the first computer booted, but on the second it fails with the useless error 2184:  "the service has not been started" (and it's more than useless "net helpmsg 1284" suggestion which merely repeats the same worthless phrase).  Reversing the boot order reverses the computers that succeed and fail with "net view".  The computer that boots first becomes the Master Browser and is the only one that can see the NAS in the Network portion of File Explorer.  On both computers, the mapped Z: drive to the NAS always works and browsing to the NAS' IP address or hostname works just fine.  It's just not showing up in Network.



  • pfSense has nothing to do with your LAN devices connected to a switch seeing each other.



  • @fragged:

    pfSense has nothing to do with your LAN devices connected to a switch seeing each other.

    That's my impression, too.  But, the OP came back and marked this thread solved.  So, maybe I'm wrong.

    Regardless, since I've never seen a solution to this, I'd like to know how he did it.



  • The Same thing happened with me.
    I setup a server (2 NIC Cards) with Pfsense 2.4.4 version and then using one NIC as WAN and other NIC as LAN.
    The users connected to LAN are not able to see each other on LAN.
    Moreover, i already configured NAS on server which is earlier working when we are using CISCO router now its not.



  • On the server which is using as Pfsense firewall via Hyper V, File sharing is also configured on same using Window server 2016 Datacenter OS.
    Now LAN sharing is not working.



  • This stuff is network 101.

    Traffic on the LAN network never never touches the firewall unless the traffic is out of the LAN subnet.

    This is only a switch function.

    Example-

    192.168.10.10 (lookup 192.168.10.25) Go direct to 192.168.10.25.

    192.168.10.10 (lookup 13.107.21.200) Go through gateway (192.168.1.1) to get to 13.107.21.200.

    In simple terms..



  • @chpalmerc
    I just did the configuration with NAT as primary (WAN) now its working for pfsenseVM.

    Any other solution?
    Basically i want to discontinue the use of Router at the backend and want to use the same server for everything.


  • Netgate Administrator

    Most likely: The LAN subnet or the DHCP server MAC address changed and now Windows sees it as an untrusted public network so is blocking requests from other clients.

    Steve


Log in to reply