OpenVPN - Site to Site



  • Prezados, bom dia.

    Tenho um cenário no qual possuo o Site A e o Site B, no Site A está meu pfSense 2.3.2 sendo o servidor OpenVPN estou utilizando chave compartilhada.

    Já configurei em ambos os firewalls tanto do Site A como no Site B, e consegui fechar a VPN, mas não consigo comunicação entre os sites. Já fiz as regras de Firewall mas não funciona pois os pacotes não estão nem chegando.

    O que notei de diferente é que na configuração do servidor na versão 2.2.4 eu informava o CIDR do túnel, o CIDR da rede local e o CIDR do site remoto mas na versão 2.3 não existe mais o campo para informar o CIDR da rede local.

    Alguém saberia me ajudar?



  • fala amigo!!!

    como esta configurado as redes remotas e túnel ?



  • Rede remota está o ip do site B CIDR ex: 172.168.x.x/24 e o túnel está o CIDR ex: 10.10.x.x/30.



  • posta as telas das configurações do openvpn e do firewall.

    está usando TUN ou TAP ?



  • Fala Chipbr.

    O que acho estranho é o fato de não ter a opção de conexão loca.




  • Não tem mesmo, o meu também não tem.

    Seu problema deve ser a configuração mesmo, alguma coisa está no lugar errado



  • @dbessa:

    Fala Chipbr.

    O que acho estranho é o fato de não ter a opção de conexão loca.

    Mude seu Algoritmo de Encriptação para: BF-CBC (128-bits)

    Depois post o feedback.



  • Configurei usando SSL/TLS e não mais pelo Shared Key e funcionou.



  • no seu print já estava shared key



  • Então chipbr, abri mão do Shared key e fiz por SSL/TLS.



  • blz, que bom que funcionou.

    mas não é esse o problema, alguma coisa devia estar errada na configuração.
    aqui eu ligo 3 filiais apenas por shared key, e funciona perfeito



  • Eu tbm uso 3 filiais com Shared Key.



  • Entendi, mas a versão de vcs é a 2.3.2? O que estranhei foi não possuir mais o campo de local network apenas das redes remotas. Mas enfim, obrigado pelo feedback depois vou fazer um lab e testar para ver o que eu estava fazendo de errado.
    Muito obrigado pelo feedback de vcs, chipbr e andrezaomac.



  • sim, uso a ultima versao 2.3.2-RELEASE-p1
    realmente não tem este campo, mas não senti falta dele

    de qualquer maneira, você aponta as redes remotas no client e não no server. Lá tem esse campo