2 DHCP servers and PfSense DHCP server won't lease



  • First of all don't shoot me, I'm a network newbie. However, I googled around for hours and tried various things… all without result.
    I hope someone can help here and tell me how to get it working.

    The challenge:
    DHCP on my Pfsense does not lease IP adresses and gives an error (see below).

    1. I have a cablemodem/router from my ISP.
      --> DHCP cannot be turned off.
      --> Address 192.168.0.1, and leasing IP's for the full range 192.168.0.2 - 192.168.0.255 (which cannot be changed)
      --> no control on firewall or any other thing, except port forwarding

    2. My goal is to use PfSense as a router right after this one, also with DHCP/NAT turned on (I know I know, double NAT is not great). However, I want more control.
      --> 2 interfaces defined, WAN & LAN
      --> WAN is set to DHCP, all settings as default
      --> LAN is set to Static IPv4 with address 192.168.1.1
      --> DHCP server is turned on:

    Subnet
    192.168.1.0
    Subnet mask
    255.255.255.0
    Available range
    192.168.1.1 - 192.168.1.254
    Lease Range set from 192.168.1.10 to 192.168.1.50

    This setup just doesn't work... and the weird things is also: I'm receiving an IP address of 192.168.1.100 when connecting a pc on the LAN side ... also Internet works.

    Error log DHCP server shows:
    Feb 3 22:56:52 dhcpd Wrote 0 leases to leases file.
    Feb 3 22:56:52 dhcpd Listening on BPF/ue0/00:60:6e:42:f3:52/192.168.1.0/24
    Feb 3 22:56:52 dhcpd Sending on BPF/ue0/00:60:6e:42:f3:52/192.168.1.0/24
    Feb 3 22:56:52 dhcpd Can't bind to dhcp address: Address already in use
    Feb 3 22:56:52 dhcpd Please make sure there is no other dhcp server
    Feb 3 22:56:52 dhcpd running and that there's no entry for dhcp or
    Feb 3 22:56:52 dhcpd bootp in /etc/inetd.conf. Also make sure you
    Feb 3 22:56:52 dhcpd are not running HP JetAdmin software, which
    Feb 3 22:56:52 dhcpd includes a bootp server.
    Feb 3 22:56:52 dhcpd If you think you have received this message due to a bug rather
    Feb 3 22:56:52 dhcpd than a configuration issue please read the section on submitting
    Feb 3 22:56:52 dhcpd bugs on either our web page at www.isc.org or in the README file
    Feb 3 22:56:52 dhcpd before submitting a bug. These pages explain the proper
    Feb 3 22:56:52 dhcpd process and the information we find helpful for debugging..
    Feb 3 22:56:52 dhcpd exiting.



  • It is fixed… by updating PfSense to the latest release. I thought I already had the latest since I only did the setup yesterday.
    It seems there was an issue somehow in that version with DHCP...

    ...and now I get an IP lease of 192.168.1.10 - which is what I expected:-)

    Current version now is:
    2.3.2-RELEASE-p1 (amd64)
    built on Tue Sep 27 12:13:07 CDT 2016
    FreeBSD 10.3-RELEASE-p9

    The system is on the latest version.


Log in to reply