Unable to perform 1:1 NAT on secondary WAN ports



  • I am a 1Gb/1Gb connection as my primary WAN port and a 50Mb/50Mb connection as the secondary port.
    I have an Asterisk/FreePBX VoIP box connected via NAT to the secondary and I wan all the SIP traffic to do out the secondary WAN.
    However, I am unable to get a 1:1 NAT to work correctly on the secondary WAN (with any machine not just the FreePBX box).  I have no problem whatsoever with 1:1 NATs on the primary WAN port, including NAT reflection.  Everything works correctly.  But when I try the same settings (with the exception of the gateway settings for the secondary WAN and IP address, of course).  It just will not work.  I get the first IP address of the primary WAN port no matter what I do!
    Any suggestions will be appreciated.
    Thanks!
    -Brian



  • What version of pfSense are you running?

    Physical interfaces for both WAN's?  Or VLAN's??

    Need more info!




  • @chpalmer:

    What version of pfSense are you running?

    Physical interfaces for both WAN's?  Or VLAN's??

    Need more info!

    Sorry/
    Its ver. 2.3.3-DEVELOPMENT
    However it has acted the same way on previous versions.
    Thanks!
    -Brian


Log in to reply