Added NIC not seen



  • Hello,

    I added an Intel PWLA8494GT Pro/1000 GT Quad Port NIC and it seems that the OS only sees two of the ports. It calls them em0 and em1.

    I thought I might try installing the drivers, but can't seem to find any for FreeBSD.

    Is it "safe" to try the Linux drivers???

    Thanks for any advice!!


  • Banned

    @x2desmit:

    Is it "safe" to try the Linux drivers???

    No, absolutely will NOT work. And define "not seen".



  • Thanks for the advice.

    By missing, I mean when I do an ifconfig from the shell, I only see two of the 4 ports.

    The output of ifconfig is below…em0 and em1 are the two new nics.

    I'm wondering if this NIC is fully supported by FreeBSD itself.

    [2.3.2-RELEASE][root@pfsense.dswhat.us]/root: ifconfig
    bge0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    	options=8009b <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum,linkstate>ether 00:16:35:6b:37:ad
    	inet6 fe80::216:35ff:fe6b:37ad%bge0 prefixlen 64 scopeid 0x1 
    	nd6 options=21 <performnud,auto_linklocal>media: Ethernet autoselect (1000baseT <full-duplex>)
    	status: active
    bge1: flags=8802 <broadcast,simplex,multicast>metric 0 mtu 1500
    	options=8009b <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum,linkstate>ether 00:16:35:6b:37:ac
    	inet6 fe80::216:35ff:fe6b:37ac%bge1 prefixlen 64 tentative scopeid 0x2 
    	nd6 options=21 <performnud,auto_linklocal>media: Ethernet autoselect
    em0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    	options=9b <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum>ether 00:11:25:cb:e8:1e
    	inet6 fe80::211:25ff:fecb:e81e%em0 prefixlen 64 scopeid 0x3 
    	nd6 options=21 <performnud,auto_linklocal>media: Ethernet autoselect (1000baseT <full-duplex>)
    	status: active
    em1: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    	options=9b <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum>ether 00:11:25:cb:e8:1f
    	inet6 fe80::211:25ff:fecb:e81f%em1 prefixlen 64 scopeid 0x4 
    	nd6 options=21 <performnud,auto_linklocal>media: Ethernet autoselect (1000baseT <full-duplex>)
    	status: active
    dc0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    	options=80008 <vlan_mtu,linkstate>ether 00:04:5a:69:86:08
    	inet6 fe80::204:5aff:fe69:8608%dc0 prefixlen 64 scopeid 0x5 
    	nd6 options=21 <performnud,auto_linklocal>media: Ethernet autoselect (none)
    	status: no carrier
    pflog0: flags=100 <promisc>metric 0 mtu 33184
    pfsync0: flags=0<> metric 0 mtu 1500
    	syncpeer: 224.0.0.240 maxupd: 128 defer: on
    	syncok: 1
    enc0: flags=0<> metric 0 mtu 1536
    	nd6 options=21 <performnud,auto_linklocal>lo0: flags=8049 <up,loopback,running,multicast>metric 0 mtu 16384
    	options=600003 <rxcsum,txcsum,rxcsum_ipv6,txcsum_ipv6>inet 127.0.0.1 netmask 0xff000000 
    	inet6 ::1 prefixlen 128 
    	inet6 fe80::1%lo0 prefixlen 64 scopeid 0x9 
    	nd6 options=21 <performnud,auto_linklocal>ovpns1: flags=8051 <up,pointopoint,running,multicast>metric 0 mtu 1500
    	options=80000 <linkstate>inet6 fe80::216:35ff:fe6b:37ad%ovpns1 prefixlen 64 scopeid 0xa 
    	inet 192.168.5.1 --> 192.168.5.2 netmask 0xffffff00 
    	nd6 options=21 <performnud,auto_linklocal>Opened by PID 67592
    [2.3.2-RELEASE][root@pfsense.dswhat.us]/root:</performnud,auto_linklocal></linkstate></up,pointopoint,running,multicast></performnud,auto_linklocal></rxcsum,txcsum,rxcsum_ipv6,txcsum_ipv6></up,loopback,running,multicast></performnud,auto_linklocal></promisc></performnud,auto_linklocal></vlan_mtu,linkstate></up,broadcast,running,simplex,multicast></full-duplex></performnud,auto_linklocal></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum></up,broadcast,running,simplex,multicast></full-duplex></performnud,auto_linklocal></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum></up,broadcast,running,simplex,multicast></performnud,auto_linklocal></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum,linkstate></broadcast,simplex,multicast></full-duplex></performnud,auto_linklocal></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum,linkstate></up,broadcast,running,simplex,multicast> 
    

  • Banned

    Go to Interfaces - Assign. Pick up the interface. Assign.



  • If it's not seen by the OS, it's won't show in the assign interfaces.



  • This NIC is well known and should be supported by FreeBSD/pfSense. You must try different OS liveUSB/DVD to make sure that you hardware is OK and working fine.



  • Excellent idea. Thanks for all the advice!!  8)


Log in to reply