Troubleshooting upgrade from 2.1.2-RELEASE to 2.3.2-RELEASE-p1



  • I am trying to upgrade from 2.1.2-RELEASE to 2.3.2-RELEASE-p1 via the auto updater on my Netgate M1n1wall.

    I have tried both the official mirror and the netgate mirror hardcoded in the settings. It's the nanobsd 4g image.

    I have tried both the GUI and Terminal upgrade.

    When performing the upgrade via the terminal, it downloads, upgrades, says it's complete and is going to reboot, then it reboots back into 2.12.

    This is at a remote location far far away from me so I am cautious to try anything else right now. My 4 other M1n1wall locations worked, granted only 2.3.1 was out when I did those.

    How can I go about troubleshooting this?


  • Banned

    Wouldn't bother. Do a clean install and restore the config.


  • Netgate Administrator

    The first thing to check here is the upgrade log in /conf. That should show why it chose not to switch slices.

    If it's sufficiently remote that recovery is going to be an issue you may opt to wait until you can be on site with a newly flashed 4GB card and just restore the old config into it.

    Steve



  • Looks like I am screwed: https://forum.pfsense.org/index.php?topic=75069.0

    I have that exact issue. Looks like I will be overnighting a restored one.


  • Netgate Administrator

    Ah, yes no way I know of to recover from that if you're seeing those errors.

    A fresh CF card is the safest way anyway. You still have the old one to boot from if there's an issue.

    Steve


Log in to reply