Bandwidthd woes summary



  • Just wanted to post a latest summary of bandwidthd problems.
    Out of the box with the latest 1.2.1 it does not work.  From what I have found…..
    1. you need to ssh to the system and use this command
    pkg_add -r libiconv

    now the service will get a little furthur, but will give you a syslog error on line 52.  this is a problem with the default setting in pfsense via the web interface.  the filter in the web interface is set to a default of "IP" and that causes it to crash.  I gave up on changing the config via pfsense, as there are obviously problems here.

    what I did was ssh to the box (used putty) and manually configure the config file and changed it to match the one I downloaded from the author.
    chdir /usr/local/bandwidthd/etc
    ee bandwidthd.conf

    I commented out everything except the following few lines(and added the subnet).  I set for monitoring my local network...

    subnet 192.168.0.0 255.255.255.0
    dev "em0"
    promiscuous true

    and NOW it works!!!!

    Hopefully this package will be fixed in the future, as everything else that I have tried does not give me nice quick info like this.  pfflowd works, but does not log both directions, and is a paint to keep another machine running.  Built in traffic log resets at 4gig, so there really is a demand for a package like this.  Hopefully this info helps others, as I struggled with this.  Being a newb makes it a real challenge.  a week ago I was not sure what ssh was :)


Locked