DHCP no free leases ?



  • Hello community,

    ive tried to find a solution for my problem at this forum, but i think my problem is different from those which were already posted here.

    Our PFSense server worked fine for a half year now. Nothing changed and since 2 days it says no free leases. Of course the number of used Leases increased every few weeks.

    Feb 7 18:40:39 dhcpd DHCPDISCOVER from 98:97:d1:ae:87:dd via fxp1: network 192.168.2.0/23 no free leases.

    I checked up how many leases are used. There are 149 leases used with the expired ones. I decreased the maximum expiration time to 7200 seconds. Still no device gets any connection to the internet.

    the range is now from:

    192.168.2.1 - 192.168.3.254

    And used range is:

    192.168.2.5 - 192.168.3.254

    There should be many more free leases than those which are used ? We added a dhcp static mapping for every user to use the mac filter. Everything worked fine and we didnt make any changes. How can i check if this is even the right error message which is causing those problems? i assumed it is, because it is always the latest message in the dhcp log. Ive restarted the whole server twice now, and the dhcp server module.

    Hopefully you can help me out.

    Greetings
    Justin



  • Hi

    Did you ever resolve this issue?  I'm seeing exactly the same thing.

    Basically the pfSense box will not send a DHCPOFFER for any new hosts that don't have an active lease, even if they are static mappings.  It's quite happy to renew existing leases but won't offer new ones.

    I've tried the tricks that people have mentioned on forums here about granting global write permissions on the dhcpd.leases file but it's made no difference.

    Many thanks
    Stuart



  • This happened to me too (yesterday) on a 2.3.2_p1 system with 2 physical WANs, 2 physical LANs and 1 VLAN. System is otherwise stable.  Checked DHCP status and there were >100 free leases available.

    The only thing I could do to get things working quickly again was to go to Status > Services and STOP dhcpd. Wait 5s, and then start the service again. Before that I tried the "Restart" service button several times but that just spit out errors in the dhcp log "Internet Systems Consortium DHCP Server 4.3.5 blah blah"



  • Yep, that did the trick, thanks!