I can't upgrade from 2.3.1-RELEASE (amd64) to the lastest version



  • Hello. I'm trying to upgrade my pfsense 2.3.1-RELEASE (amd64) to the lastest version through the web interface, and when I reboot the machine still are on 2.3.1 version.
    looking on the forum, and I saw that some people solve the problem executing the upgrade from the console with:

    pkg update -f

    pfSense-upgrade -d

    Not works for me…
    I receive this output:

    root: pfSense-upgrade -d

    Updating repositories metadata...
    Updating pfSense-core repository catalogue...
    pfSense-core repository is up-to-date.
    Updating pfSense repository catalogue...
    pfSense repository is up-to-date.
    All repositories are up-to-date.

    Unlocking package pfSense-kernel-pfSense...
    Unlocking pfSense-kernel-pfSense-2.3.2_1
    The following 59 package(s) will be affected (of 0 checked):

    New packages to be INSTALLED:
            dnsmasq: 2.76,1 [pfSense]

    Installed packages to be UPGRADED:
            xinetd: 2.3.15_1 -> 2.3.15_2 [pfSense]
            smartmontools: 6.4_2 -> 6.5_1 [pfSense]
            relayd: 5.5.20140810_1 -> 5.5.20140810_2 [pfSense]
            php56-zlib: 5.6.21 -> 5.6.26 [pfSense]
            php56-xmlwriter: 5.6.21 -> 5.6.26 [pfSense]
            php56-xmlreader: 5.6.21 -> 5.6.26 [pfSense]
            php56-xml: 5.6.21 -> 5.6.26 [pfSense]
            php56-tokenizer: 5.6.21 -> 5.6.26 [pfSense]
            php56-sysvshm: 5.6.21 -> 5.6.26 [pfSense]
            php56-sysvsem: 5.6.21 -> 5.6.26 [pfSense]
            php56-sysvmsg: 5.6.21 -> 5.6.26 [pfSense]
            php56-sqlite3: 5.6.21 -> 5.6.26 [pfSense]
            php56-sockets: 5.6.21 -> 5.6.26 [pfSense]
            php56-simplexml: 5.6.21 -> 5.6.26 [pfSense]
            php56-shmop: 5.6.21 -> 5.6.26 [pfSense]
            php56-readline: 5.6.21 -> 5.6.26 [pfSense]
            php56-posix: 5.6.21 -> 5.6.26 [pfSense]
            php56-pdo_sqlite: 5.6.21 -> 5.6.26 [pfSense]
            php56-pcntl: 5.6.21 -> 5.6.26 [pfSense]
            php56-openssl: 5.6.21 -> 5.6.26 [pfSense]
            php56-opcache: 5.6.21 -> 5.6.26_1 [pfSense]
            php56-mcrypt: 5.6.21 -> 5.6.26 [pfSense]
            php56-mbstring: 5.6.21 -> 5.6.26 [pfSense]
            php56-ldap: 5.6.21 -> 5.6.26 [pfSense]
            php56-json: 5.6.21 -> 5.6.26 [pfSense]
            php56-hash: 5.6.21 -> 5.6.26 [pfSense]
            php56-gettext: 5.6.21 -> 5.6.26 [pfSense]
            php56-filter: 5.6.21 -> 5.6.26 [pfSense]
            php56-curl: 5.6.21 -> 5.6.26 [pfSense]
            php56-ctype: 5.6.21 -> 5.6.26 [pfSense]
            php56-bz2: 5.6.21 -> 5.6.26 [pfSense]
            php56-bcmath: 5.6.21 -> 5.6.26 [pfSense]
            php-xdebug: 2.2.5 -> 2.4.0 [pfSense]
            pfSense-rc: 2.3.1 -> 2.3.2_1 [pfSense-core]
            pfSense-pkg-squid: 0.4.23_1 -> 0.4.35_3 [pfSense]
            pfSense-pkg-snort: 3.2.9.1_14 -> 3.2.9.2_16 [pfSense]
            pfSense-pkg-pfBlockerNG: 2.1.1_4 -> 2.1.1_6 [pfSense]
            pfSense-pkg-openvpn-client-export: 1.3.13 -> 1.4.1 [pfSense]
            pfSense-pkg-mailreport: 3.0_1 -> 3.1 [pfSense]
            pfSense-pkg-haproxy: 0.48 -> 0.48_1 [pfSense]
            pfSense-pkg-RRD_Summary: 1.3.1_2 -> 1.3.2_2 [pfSense]
            pfSense-default-config: 2.3.1 -> 2.3.2_1 [pfSense-core]
            pfSense-base: 2.3.1 -> 2.3.2_1 [pfSense-core]
            pfSense-Status_Monitoring: 1.3_1 -> 1.4.4_2 [pfSense]
            pfSense: 2.3.1 -> 2.3.2_1 [pfSense]
            pecl-radius: 1.2.7 -> 1.3.0 [pfSense]
            openvpn-client-export: 2.3.11 -> 2.4 [pfSense]
            ntp: 4.2.8p7 -> 4.2.8p8 [pfSense]
            nginx: 1.8.1,2 -> 1.10.1,2 [pfSense]
            isc-dhcp43-server: 4.3.3P1_1 -> 4.3.4 [pfSense]
            isc-dhcp43-relay: 4.3.3P1_1 -> 4.3.4_1 [pfSense]
            isc-dhcp43-client: 4.3.3P1_1 -> 4.3.4 [pfSense]
            ipmitool: 1.8.15_1 -> 1.8.17_1 [pfSense]
            filterlog: 0.1_2 -> 0.1_4 [pfSense]
            clamav: 0.99.1 -> 0.99.2 [pfSense]
            c-icap: 0.4.2,2 -> 0.4.3,2 [pfSense]
            bind-tools: 9.10.3P4 -> 9.10.4P2 [pfSense]

    Installed packages to be REINSTALLED:
            scponly-4.8.20110526_2 [pfSense] (options changed)

    Number of packages to be installed: 1
    Number of packages to be upgraded: 57
    Number of packages to be reinstalled: 1

    The process will require 6 MiB more space.

    **** WARNING ****
    Reboot will be required!!
    Proceed with upgrade? (y/N) Y
    Aborting…

    Locking package pfSense-kernel-pfSense...
    Locking pfSense-kernel-pfSense-2.3.2_1

    Some ideas?
    Thanks.


  • Banned

    Try with lowercase y. Not Y.



  • Hello.
    I launched the upgrade from console (Typing y instead Y), but my system is still in 2.3.1 after reboot.
    Where can I found logs for find possible causes?
    Thanks.


  • Rebel Alliance Developer Netgate

    Was the console output the same?

    It would only say "Aborting…" if you didn't type "y"



  • Hello.
    I typed "y" instead "Y" and the system rebooted without errors
    But after rebooted,  the version is still the the 2.3.1

    How can I debug the startup process?
    Thanks.


  • Rebel Alliance Developer Netgate

    Show us what the output/log contains from what you tried that



  • Hello.
    Today I launched the new 2.3.3 upgrade and it was successfuly.
    Thank you at all.


Log in to reply