PFSence and a simple 5 port switch



  • Hello,

    Hoping someone here will be able to help me out with a PFSence Model 5G-2440 that I am having some issues with.

    I have a Comcast fiber modem at a hotel that I am trying to manage.  I only have one port on the modem available for internet (other is being used for phones)  I need to get the PFSence and the back office to all run off of port 1.  I can plug the router for the back office in to a switch (that is connected to port 1) and get internet from it, but any time I plug the PFSence box into the switch it just does not even register on the switch.  No lights, no internet, no nothing, like I haven't plugged anything in at all.  Does not mater what port on the switch, does not mater what cable I use.  Yet if I plug the PFSence directly into port 1 on the fiber modem it is happy and the guest wifi works.

    Any help would be awesome, I need to get this customer off of the unstable coax for all their back office machines.

    Avolow.


  • Banned

    Modem to switch to two routers?

    Dont most modems just work for one router MAC?

    This seems like it could have a lot of issues but I don't really know?

    Why not modem to pfSense to switch and just run all of your networks from the pfsense router? Can you do this or must you have two physical router's?


  • Netgate Administrator

    The most likely reason pfSense would not negotiate a link with a non-managed switch (is it?) is that the WAN port on the SG-2440 is set to a fixed speed and duplex the switch cannot match. Like the port is set to fixed 1Gbps and switch is 10/100. The "modem" may be able to match that which is why it works there.

    Check the speed/duplex settings of all the devices involved.

    Steve

    Edit: typo



  • @stephenw10:

    The most like reason pfSense would not negotiate a link with a non-managed switch (is it?) is that the WAN port on the SG-2440 is set to a fixed speed and duplex the switch cannot match. Like the port is set to fixed 1Gbps and switch is 10/100. The "modem" may be able to match that which is why it works there.

    Check the speed/duplex settings of all the devices involved.

    And, since it's 2017, everything should just be set to autonegotiate. Trying to do it manually just leads to tears.


  • Netgate Administrator

    @VAMike:

    And, since it's 2017, everything should just be set to autonegotiate.

    Yup. Yet we hit ISP supplied gear set to fixed duplex with disappointing regularity!  ::)

    Steve



  • Thank you for the replies. :)  They have given me a few things to look into when I get back out there in the next day or two.  I will definitely check the speed/duplex settings, in the box and have a gigabit switch on hand as well when I return.  Hopefully that will solve the issues and I can get it working on a switch. :)

    I'll let you all know what I find.