[solved] Setup wizard resets DHCP range?



  • Dear pfSense gurus,

    I am in the process of learning to install and configure pfSense. But I have run into the following issue.

    After the initial installation and first reboot of pfSense on the router (I am using VirtualBox for now) I am able to use the console menu to configure interfaces (option 2). Here I assign an IP address to the LAN interface and configure the DHCP server with a range of 10.1.0.200 through 10.1.0.254, like in the screenshot pfsense-console-dhcp.png.

    Then when I connect some computer to the LAN port of pfSense and enter the web interface, I am greeted with the Setup Wizard. I follow all the steps, including the bit where I can configure the LAN interface again. See screenshot pfsense-setup-lan.png. On this page I leave the settings as they are, having previously configured the address myself inside the console. So I just hit Next.

    Now I am surprised to see that after the Setup is finished, and when I go to Services -> DHCP Server, that the DHCP range has been changed to 10.1.0.10 through 10.1.0.245, as in screenshot pfsense-dhcp-server.png. So it seems as if the "Wizard" does not honour previously configured settings and it overrides my chosen DHCP range.

    The problem is easily fixed at this point so no actual harm is done. Still I wonder if I have done something weird or wrong, or if I have hit a bug in pfSense, or if I am missing something else.

    Anyone care to enlighten me? Should I have skipped the Wizard? Thank you in advance.







  • That is bug https://redmine.pfsense.org/issues/4820
    Fixed by commit https://github.com/pfsense/pfsense/commit/d02ee1387fdb159bfb7cb9495003f66545d97989
    And will be in 2.3.3 which is at the RC stage and expected to be released "real soon now".



  • Thank you, Phil Davis, for your reply. At least now I know I haven't done anything wrong and that the bug has already been solved in the next version of pfSense. As I said it is not a huge problem to begin with.

    I swear I did look at the "issues" page but it was a bit overwhelming and I was not able to find the one you mentioned.