Pfsense won't boot after power failure



  • I have been running pfsense for some time.  My install isn't heavily customized or anything, a few port forwarding rules is about all I've done beyond stock.  A few days ago my powered blinked during a storm, and now my pfsense box will not boot.  (The box was plugged into a UPS, which did not work, but that is a matter for another forum.) I am a linux newbie so my ability to "fix" things is limited without complete instructions.  I'm fairly certain that I could re-install pfsense, but I'm hoping to avoid such drastic action.

    After the power failure, I restarted the pfsense box, expecting it to reboot.  After a reasonable wait my internet did not come back so I restarted the box again.  After a few tries I realized the box was not working for some reason.  I connected a monitor and keyboard and rebooted one more time.  The box POSTs fine, and starts to load pfsense normally.  However at a point it stops and proceeds no further.  Unfortunately I have no way to screenshot the pfsense box since I am directly connected.  I couldn't retype the entire boot screen sequence, not that I really want to.  The following is last portion of the the boot process.  This sequence is preceded by what appears to be the loading of system hardware, more specifically the drives ada0 and cd0.  The lines below are the final lines on the screen before everything stops:

    SMP: AP CPU #1 Launched!
    SMP: AP CPU #2 Launched!
    SMP: AP CPU #3 Launched!
    Timecounter "TSC" frequency 1800026765 Hz quality 1000
    Trying to mount root from ufs:/dev/ufsid/5838a427785e9dc3 [rw]…

    Configuring crash dumps…
    Using /dev/label/swap0 for dump device.
    /dev/ufsid/5838a427785e9dc3: FILE SYSTEM CLEAN; SKIPPING CHECKS
    /dev/ufsid/5838a427785e9dc3: clean, 11988930 free (2714 frags, 1498277 blocks, 0.0% fragmentation)
    Filesystems are clean, continuing...
    Mounting filesystems...
    Disabling APM on /dev/ad8
    pid 55 (mdconfig), uid 0: exited on signal 11 (core dumped)

    At this point everything stops.  The screen below the text is blank with no additional error messages.  I don't have a prompt per se, but I can type on the screen, not that I know what to type.  The system in general is still responsive and it will respond to a CTRL-ALT-DEL and restart.  When it does restart, it does appear to be controlled in some fashion.  It displays a few messages (far too briefly to record) about waiting for several system process to stop; those processes are "vnlru", "bufdaemon", and "syncer".  These do stop, after which I see "syncing disks" and "buffer stopped" then several more lines to brief to catch before the system reboots.

    I know it may not be much to go on, but any help is appreciated.

    Thanks



  • might be filesystem corruption.
    Reinstalling and importing a backup of your config would be the best course of action.


  • Netgate

    Boot to single user (S at the logo menu), press RETURN for a shell when prompted and run /sbin/fsck -y /

    Keep running it until fsck stops complaining (maybe three more times).

    Then /sbin/reboot/



  • @Derelict:

    Boot to single user (S at the logo menu), press RETURN for a shell when prompted and run /sbin/fsck -y /

    Keep running it until fsck stops complaining (maybe three more times).

    Then /sbin/reboot/

    Thanks for the suggestion. Unfortunately it did not work. When I ran fsck it didn't complain, it said the file system was clean, but it also said the file system was modified so I'm not sure.  Anyway, I ran it 5 times to be certain the rebooted.  After the reboot, the results were the same as before.

    Guess it looks like reinstalling is my next move.


  • Banned

    Yeah, playing with fsck will only fsck up the UFS filesystem even more. Waste of time.