HOWTO: Notifications with GMAIL SMTP



  • This was supposed to be a question but i ended up figuring out my problem

    I kept getting “Error: 530-5.5.1 Authentication Required”

    SOLUTION –> I had to click SAVE at the bottom of the screen PRIOR to clicking Test SMTP Settings for this to work

    Thought i would go ahead and type it out to maybe help someone else out.

    go here to setup a password for pfSense
    https://security.google.com/settings/security/apppasswords
    Select App --> Other Custom Name --> Type in pfSense --> click Generate
    Copy this new password and use it below.

    Email Server: smtp.gmail.com

    SMTP Port 465

    Secure SMTP Connection --> check Enable SMTP over SSl/TLS

    From e-mail address <username>@gmail.com

    Notification E-Mail address <username>@gmail.com

    Notification E-Mail auth username (optional) <username>@gmail.com

    Notification E-Mail auth password --> USE THE NEW PASSWORD CREATED USING
    https://security.google.com/settings/security/apppasswords

    Notification E-Mail auth mechanism --> PLAIN

    CLICK --> SAVE at the bottom of the page FIRST THIS IS THE ONLY WAY IT WORKED FOR ME

    CLICK --> test  SMTP settings</username></username></username>



  • It appears google app passwords are a part of the paid google services (as of Jan 2018). If you try to use the above URL’s to get an app password you will see “The setting you are looking for is not available for your account. GO TO MY ACCOUNT”.

    What you must do is set up the page as shown in OP, with your regular gmail password. Click test a couple times and it will fail. Then go log into that account and look for the security messages saying account access was blocked. You must click “this was me” and allow the connection. Further test email in pfsense should work then.

    Probably a good idea to not use your main gmail account to send from due to this, just register a secondary.



  • It’s still working on my gmail account. I’ve got passwords set up for a couple different things and they work just fine. Make sure you have 2FA enabled on your account and you shouldn’t have any issues.



  • I just wanted to say Thank You for doing this.  I know it’s easy enough to figure out on my own.  But sometimes finding stuff in the Google settings is a PITA.
    Plus, not actually having to figure stuff out is a nice change of pace.

    Great post.  Quick, easy, and to the point. 
    Thank you again for taking the time to do this.

    Eboman


  • Rebel Alliance

    Yeah app passwords still work… Not sure where you read that you need paid account from Jan 2018?



  • @Eddie55:

    This was supposed to be a question but i ended up figuring out my problem

    I kept getting “Error: 530-5.5.1 Authentication Required”

    SOLUTION –> I had to click SAVE at the bottom of the screen PRIOR to clicking Test SMTP Settings for this to work

    CLICK --> SAVE at the bottom of the page FIRST THIS IS THE ONLY WAY IT WORKED FOR ME

    CLICK --> test  SMTP settings

    This was bedeviling me - thank you!

    Hopefully this bug (if indeed it is a bug) can be addressed.



  • I don’t see how this is a bug when it clearly says

    The last SAVED values will be used, not necessarily the values entered here.

    Directly below the TEST button.


 

© Copyright 2002 - 2018 Rubicon Communications, LLC | Privacy Policy