Multiplos IPs externos mas em redes diferentes



  • Bom dia, estou com problemas com meu pfsense.
    estou removendo o site e os emails do serviço de hospedagem e trazendo para dentro da empresa.

    tenho 3 IPs externos que vou chamar de
    1.1.1.1 –> WAN designada pelo meu provedor (ip fixo) mas conecta por PPPoE
    2.2.2.1/30 --> IP externo 1
    2.2.2.2/30 --> IP Externo 2
    o primeiro é a WAN, funciona perfeitamente
    os outros 2 estão em outra rede

    O que eu quero fazer, designar um IP externo para o meu DNS e outro para o servidor de EMAIL.
    Já adicionei os endereços como virtual IP e fiz um NAT 1:1, mas não consigo acesso externo a nenhum serviço, mesmo fazendo os redirecionamentos de porta.

    Sei que estou fazendo algo errado, mas não acho o que.

    Se alguém puder me dar uma ajuda



  • Poste tuas regras de NAT.



  • Obrigado por se propor a ajudar Elias
    Seguem as regras que eu tenho.




  • Bom, se tu já tem os IPs públicos configurados no Virtual IPs, faça o seguinte.

    Em Firewall > NAT > Port Forward crie uma regra e complete de acordo com as tuas configurações seguindo o anexo.

    A outra regra é só seguir o exemplo.




  • Seus outros dois ips estão configurados em qual interface?

    Aparentemente você criou os outros nats na wan, quando deveria colocar a interface onde eles estão configurados.



  • marcelloc, desculpe a demora na resposta.

    Os endereços estão configurados na interface wan, como IP ALIAS.

    Fisicamente só tenho espaço para mais uma placa nesse pfsense.

    Elias, tentei criar as regras como você descreveu, mas não obtive sucesso.



  • @fepupo:

    marcelloc, desculpe a demora na resposta.

    Os endereços estão configurados na interface wan, como IP ALIAS.

    Fisicamente só tenho espaço para mais uma placa nesse pfsense.

    Elias, tentei criar as regras como você descreveu, mas não obtive sucesso.

    Esses dois IPs que tu configurou no Virtual IP pertencem a mesma rede? Você os recebeu do teu provedor?



  • não, estão em outra rede.
    ja tentei pedir no provedor para que fossem colocados na mesma rede, mas eles me negam isso



  • @fepupo:

    não, estão em outra rede.
    ja tentei pedir no provedor para que fossem colocados na mesma rede, mas eles me negam isso

    Que mascara é esse teu bloco?



  • bom dia  empbilly
    meu link chega em outra rede, estou tentando negociar com o provedor para deixar tudo na mesma rede.
    me deram o seguinte bloco 177.92.16.xxx/30



  • @fepupo:

    bom dia  empbilly
    meu link chega em outra rede, estou tentando negociar com o provedor para deixar tudo na mesma rede.
    me deram o seguinte bloco 177.92.16.xxx/30

    Com certeza na mesma rede fica mais fácil.



  • Andei refazendo as coisas por aqui.

    Não sei que erro cometi que não consigo mais acessar o pfsense quando estou fora da empresa, só consigo acessar quando conecto por VPN, até ai, sem problemas, é melhor assim.

    A estrutura montei da seguinte forma agora (desenho tosco abaixo)

    ______ link principal entra na WAN do pfsense –--|
    link_provedor -->switch--->|                                                                          |------>pfsense
                                              |______Range contratado entra na opt2  _______|

    No pfsense a placa OPT2 recebe o meu primeiro ip valido do range
    o segundo endereço do range, eu atribui como um virtual ip e fiz um NAT 1:1 para um servidor interno

    mas infelizmente isso não resolveu.
    Percebi uma coisa, quanli libero o ICMP para o pfsense, independente de qual ip eu pingar (o do link principal ou do range), tenho resposta
    Se eu pingo para o endereço que fiz o nat 1:1 tenho resposta também, então desliguei o cabo desse servidor e continuei obtendo resposta, ou seja, quem está respondendo é o pfsense.
    Desabilitei a regra de icmp da wan e criei na opt2, e ninguem responde, nem o pfsense, muito menos o servidor.


Log in to reply