Captive Portal + Proxy Https não funciona



  • Bom dia pessoal, eu uso o pfSense 2.3.2 e tenho o seguinte cenário.

    Proxy HTTP e HTTPS transparente com certificado, configurei o Captive Portal autenticando com servidor Radius integrado com meu AD, até ai tudo bem, o problema é que a tela de autenticação do Captive não abre quando acesso sites HTTPS e como a maioria dos portais como terra, uol, google etc, ele não abre e da erro de pagina como se não estivesse conectado a internet, mais quando entro em um site HTTP ele pede a autenticação, após a validação do usuário a navegação flui normal.

    Alguém já passou por isso?



  • @waldirscruz:

    Bom dia pessoal, eu uso o pfSense 2.3.2 e tenho o seguinte cenário.

    Proxy HTTP e HTTPS transparente com certificado, configurei o Captive Portal autenticando com servidor Radius integrado com meu AD, até ai tudo bem, o problema é que a tela de autenticação do Captive não abre quando acesso sites HTTPS e como a maioria dos portais como terra, uol, google etc, ele não abre e da erro de pagina como se não estivesse conectado a internet, mais quando entro em um site HTTP ele pede a autenticação, após a validação do usuário a navegação flui normal.

    Alguém já passou por isso?

    Resumidamente: HTTPS é feito para impedir que os usuários sejam redirecionados.
    Captive Portal é feito para redirecionar os usuários forçadamente para um portal de autenticação.

    São opostos. Briguei muito com isso mas não consegui nada que solucionasse essa questão especifica de abrir HTTPS. O que pode fazer para sanar o problema é habilitar a opção "Logout popup window - Enable logout popup window  - If enabled, a popup window will appear when clients are allowed through the captive portal. This allows clients to explicitly disconnect themselves before the idle or hard timeout occurs." Cujo forçará abrir a pagina especifica no portal de autenticação, sem precisar que o usuário tente navegar. De qualquer forma já deixe avisado que se não abrir automaticamente, o usuário deve tentar entrar no site "globo.com" é o HTTP que adoto como padrão para essa situação.



  • @waldirscruz:

    Bom dia pessoal, eu uso o pfSense 2.3.2 e tenho o seguinte cenário.

    Proxy HTTP e HTTPS transparente com certificado, configurei o Captive Portal autenticando com servidor Radius integrado com meu AD, até ai tudo bem, o problema é que a tela de autenticação do Captive não abre quando acesso sites HTTPS e como a maioria dos portais como terra, uol, google etc, ele não abre e da erro de pagina como se não estivesse conectado a internet, mais quando entro em um site HTTP ele pede a autenticação, após a validação do usuário a navegação flui normal.

    Alguém já passou por isso?

    O primeiro acesso precisa ser HTTP.
    https://doc.pfsense.org/index.php/Captive_Portal_Troubleshooting