Ethernet issues on ONE machine after a hardware failure on pfSense gw



  • Here the other night my pfSense machine stopped working due to a failing power supply. Power supply has been replaced and all items up'n'running again - except ONE computer. My main setup is one WAN, one LAN and a WLAN net, and all interfaces are on private IP ranges.
    My main issue is to get the pfsense gateway / firewall to accept the ethernet interface that are registered with MAC address and a fixed IP. The machine sees ALL other machines within the same network segment (as it should) but there is no access through the gateway to internet. Have added in a firewall rule specific for this IP address with logging, but it shows nix nada traffic coming to the gateway/firewall. So it seems like it 'disapear' even before it gets that far.
    I am a bit stuck, I've tried different IP's, different segments, multiple IP addresses for the eth0 etc etc. I am going to remove the ARP segment for this machine, and remove and reenter MAC/IP pair (again!) to see if it could help. I'll also open up for ICMP on the gateway so I at least can ping it from the inside.
    Any other tips to get this solved would be highly appreciated.

    Knottolf



  • Have tried to remove the address from the ARP, reset the MAC/IP settings but still no luck. So the next steps is going to be:
    **- Replace an old small little switch located in the room where the troublesome machine is located (Multiple machines located close by)

    • If still no luck then I have to conclude that the Ethernet port might be somewhat faulty and then**
      *** EITHER ***
      – Replace the machine through guarantee (it is 2 months old)
      *** OR ***
      – Add in an USB3-Ethernet adapter

    My fingers are crossed for having good luck with the replacement switch…  8)

    Knottolf