Clamd Stopping - Kernel (clamd) exited on Signal 11



  • Hi Everyone!!

    After spending hours trying to find an answer to this I am hoping someone may have some pointers.

    We have a pfsense instance were for some unknown reason the clam daemon will randomly stop (knocking out squid) and need restarting. From the logging we are getting the below message from the system:

    Feb 16 10:06:25 kernel pid 79861 (clamd), uid 106: exited on signal 11

    Now as this is a kernel error is the issue something within FreeBSD?

    I did think the issue could be linked to when an update is carried out, I did see this once when I ran freshclam manually. However I cannot recreate the behavior, freshclam is very happy everytime I run an update.

    Has anyone experienced anything like this before? Is there anyway to restart the clamd via CLI on pfsense, worse case if this is possible I can produce a script to check the service is running an restart it if not.

    Any pointers on this would be great.

    Thanks
    Stephen

    pfsense version = 2.3.2-RELEASE-p1 (amd64) / squid version = 0.4.35_3 / squidGuard = 1.14_4


  • Rebel Alliance Developer Netgate

    Signal 11 is usually, but not always, hardware or physical in nature. Flaky power, failing RAM, overheating, etc.

    It could also be there is a bug or other flaw in that version of clamd that crashes when it encounters a certain type of malware, in which case a future update might help.

    You could use the Service Watchdog package to keep an eye on clamd and restart it if it stops, but I'd test the hardware first.



  • Thanks Jimp,

    The pfsense is actually running within Vmware, so I can't think it is anything physical. It does have the vmware guest tools on as well.

    I am liking the looks of this service watchdog though, that would cover up this issue for the time being and keep us going. Hoping you are right in suggesting this is a bug, we have two instances both on the same versions, same vmware environment and only this one is failing.

    Maybe this is something we will just have to see how it plays out. It had been working fine until recently.

    S