2.3.4 to 2.4 Upgrade - Trying to mount root from ufs://dev/ad4s1a



  • Was doing some testing on my Intel D2500 board, but now pfSense won't boot after going from 2.3.4 built on Feb 14 to the latest 2.4 build. I've tried switching from AHCI to Legacy mode, but the issue still persists so it's back to AHCI. Can anyone explain what this means, or if there is a way to salvage my install?

    I do have autoconfig backups available, so might just reinstall to stable and revert to that backup if I have to start over.

    Thanks in advance!



  • I do see this in the troubleshooting boot wiki, but I haven't tried it yet. I'm finally back in the office and have a chance to do some proper research as opposed to just using my phone. Looks promising as it matches the exact error, but I'm curious what in 2.4 changed to require this modification.

    "Fake" RAID cards with a GRAID error
    
    Certain "fake" RAID cards, driver/software-based RAID adapters that are not true hardware RAID, may fail to mount properly with the following error:
    
    Root mount waiting for: GRAID
    mountroot>
    
    Another symptom can be that "Intel RAID" messages are shown during the boot sequence, and typing ? at the mountroot prompt it only shows the drive itself and no partitions:
    
    Mounting from ufs:/dev/ada0s1a failed with error 19
    mountroot> ?
    [...]
    ada0
    
        Escape to a loader prompt during bootup and run:
    
    set kern.geom.raid.enable="0"
    boot
    
        After a successful install/boot, add that settings permanently to /boot/loader.conf.local:
    
    kern.geom.raid.enable="0"
    

  • Rebel Alliance Developer Netgate

    Look in your boot log, just above the mountroot output. It shows the disk was detected as "ada0", and it's trying to mount ada4.

    Try mounting "ufs:/dev/ada0s1a" and it should work.

    You will need to fix references in /etc/fstab and then perhaps once you get that fixed and you confirm a reboot works, run /usr/local/sbin/ufslabels.sh to convert your fstab file over to ufs labels rather than using device names.

    Or reinstall 2.4 with ZFS and leave UFS behind.



  • @jimp:

    Look in your boot log, just above the mountroot output. It shows the disk was detected as "ada0", and it's trying to mount ada4.

    Try mounting "ufs:/dev/ada0s1a" and it should work.

    You will need to fix references in /etc/fstab and then perhaps once you get that fixed and you confirm a reboot works, run /usr/local/sbin/ufslabels.sh to convert your fstab file over to ufs labels rather than using device names.

    Or reinstall 2.4 with ZFS and leave UFS behind.

    Great catch - something I overlooked when looking at the screenshot. I'll give it a shot. Thanks!