Turned everything off for cleaning and now speed issues



  • So after deciding to take down my entire home network for maintenance, I turned everything back on to notice a major decrease in LAN throughput.

    I have an Ubuntu 16.04.2 LTS server running (VLan 75), my desktop computer running Windows 10 Education (VLan 10), Cisco 3560G, and pfSense.  All Gig on 5e.

    My desktop and the ubuntu box can iperf to the gateway at ~980 Mbit/s with default options.  My default iperf2 on my desktop while in server mode is a TCP Window Size of 208 KByte while my default setting on the ubuntu when connecting / serving is now 853 KByte.  Prior to the maintenance I would easily see transfer speeds of 70 MB/s - 110 MB/s depending on what I was reading/writing to.  Now I am lucky to get 25 MB/s after nothing more than a shut down / air can & cable check on default iperf and samba transfers if on different vlans and 43-48 MB/s if on the same vlan.

    With iPerf if I specify the window size of -w 64KB then I can get ~980 MBit/s across VLANs.  No specifying window size between these guys and I get ~245 MBit/s, throw them both on the same VLAN and default settings I'll get full speed with or without window specification (only in iPerf, not transferring).  I am noticing the major slow down when it goes to pfSense to route across VLANs.. so what happened?

    There is no snort on LAN side, and the hardware is a dual core @ 3.4 GHz w/ 4 GB ram. Watching system activity and usage, nothing spikes or hangs, I just can't figure out how to trouble shoot what is causing the slow down inter-VLAN.

    Note: Turned on a few other machines running 'nix or windows and still across vlans I am lucky to squeeze out 25 MB/s transfers on seperate and ~45 on the same vlan.    As of midnight, after attempting to transfer 40 GB files, 30s - 1 minute in, my speed plummets down to 10-12MB/s and holds there.

    Also after looking under ifconfig in the shell, it says Media: ethernet autoselect, does not say 1000tx or anything.. just ethernet autoselect.  The cisco switch says that port is auto1000 but is it weird that pfsense is not giving me a choice under interface to force 1000 or even show it?


Log in to reply