When enabled "squid" proxy cache uses only first WAN out of 3 available



  • I have a standard 3 WAN setup working well in loadbalancing mode.

    Once I installed "squid" as transparent proxy (from packages) I noticed that it uses only one out of my 3 wan setup, and there is no way to fix it.

    running 1.2.1 beta



  • @http://forum.pfsense.org/index.php/topic:

    General Stuff:
    If you want to make use of WANx for a service on pfSense:
    Quote from: Hoba
    You need a static route to the <remote-tunnel-endpoint-ip>/32 via <gateway-of-wan2>. All services running at the pfSense directly (like ipsec, a proxy, dnsforwarder,…) only follow the routingtable definitions.</gateway-of-wan2></remote-tunnel-endpoint-ip>

    I dont know if this will change with a future release.



  • looks like it will only switch from WAN1 to WAN2

    is there a way to make it use default loadbalancing rule?



  • All services running at the pfSense directly (like ipsec, a proxy, dnsforwarder,…) only follow the routingtable definitions.



  • For now, the best work around is set a cache server (squid or not) into a local network or DMZ other than pfsense.

    Configure in squid pfsense package the icp port and the upstream proxy to the local cache server.
    Please do not enable transparent proxy on the same interface that cache server is(loop).

    In local cache server(bsd,linux,windows,mac or other pfsense in a virtual machine) configure to accept connections from pfsense.

    finaly configure 2 rule in pfsense on cache server's interface to access all local networks via default gateway and a rule to access the internet via load balance.

    I guess in 1.3 the 'localhost' or 'all interfaces' tab will apear in rules to solve this limitation.


Log in to reply