Problema com captive portal



  • Meu servidor de pfsense captive portal+squid+squid guard

    Estou com o seguinte problema em alguns celulares, quando o usuario se conecta a minha rede wifi ele é automaticamente redirecionado para a pagina de login do captive portal mas as vezes isso n acontece e ele é redirecionado para o https://www.google.com.br e entao ele tem q colocar algum site http para ser redirecionado para o login do captive portal alguem sabe como resolver esse problema?

    OBS:No DHCP server ta setado o dns do servidor e em geral settings tmb mas mesmo assim alguns celulares redireciona para o https://www.google.com.br





  • @marcelowet:

    Meu servidor de pfsense captive portal+squid+squid guard

    Estou com o seguinte problema em alguns celulares, quando o usuario se conecta a minha rede wifi ele é automaticamente redirecionado para a pagina de login do captive portal mas as vezes isso n acontece e ele é redirecionado para o https://www.google.com.br e entao ele tem q colocar algum site http para ser redirecionado para o login do captive portal alguem sabe como resolver esse problema?

    OBS:No DHCP server ta setado o dns do servidor e em geral settings tmb mas mesmo assim alguns celulares redireciona para o https://www.google.com.br

    Você fez uma página personalizada pro seu Captive Portal ??? Se sim reseta pro default que o erro pode estar lá!

    Outra coisa que faço quando isso acontece eh vou no navegador do celular de preferência o chrome e digito http://ip_do_captive:8002, caso não entre eu limpo o histórico do navegador e digito novamente http://ip_do_captive:8002 que ai sim vem a página de login.
    Não tenho certeza mas vejo isso acontecendo mais em versões antigas do Android.



  • OBS:No DHCP server ta setado o dns do servidor e em geral settings tmb mas mesmo assim alguns celulares redireciona para o https://www.google.com.br

    Outra coisa importante, eu só consigo fazer isso funcionar deixando no DHCP Server da Interface do Captive Portal sendo atribuindo para os clientes  IP_DNS e IP_GATEWAY com o IP_DO_PFSENSE. Tipo se eu colocar la no DNS 8.8.8.8 não funfa =(



  • Tentei de td parece q so acontece no navegador google chrome em dispositivos androids desatualizados q redireciona para o https://www.google.com em outros navegadores ele redireciona certinho para a pagina de login

    OBS: so acontece em dispositivos androids com google chrome como navegador padrao



  • @marcelowet:

    Tentei de td parece q so acontece no navegador google chrome em dispositivos androids desatualizados q redireciona para o https://www.google.com em outros navegadores ele redireciona certinho para a pagina de login

    OBS: so acontece em dispositivos androids com google chrome como navegador padrao

    E Limpando o histórico e colocado manualmente o IP:PORTA de autenticação não abriu ?  :-\



  • @marcelowet:

    Tentei de td parece q so acontece no navegador google chrome em dispositivos androids desatualizados q redireciona para o https://www.google.com em outros navegadores ele redireciona certinho para a pagina de login

    OBS: so acontece em dispositivos androids com google chrome como navegador padrao

    Onde trabalho também acontecia isso. Sugeríamos que instalassem outro navegador no android.


Log in to reply