Preventing ipv6 timeout on ipv4 only network



  • I recently had the privilege of having Cox Gigablast installed at home (1g symmetric fiber to our closet!).  One of the lesser discussed caveats of Gigablast is that it is ipv4 only until sometime later in 2017.  Our old Cox DOCSIS 3 connection had functional ipv6.  As such, I have been experiencing ipv6 timeouts from most clients while they look for and realize there is no ipv6 connectivity.

    I have removed the ipv6 DNS servers from pfSense but this doesn't seem to help.  Clearing the 'allow ipv6 traffic' check box on System/Advanced/Networking does prevent the timeouts.  My issue is that with this checkbox cleared, I will not know when ipv6 becomes available.

    Is there a way to prevent ipv6 timeouts while still leaving the LAN/WAN/Gateways configured for ipv6 so that it will automatically 'turn on' once Cox rolls it out?


  • Banned

    You should be getting no timeouts if there's no routable IPv6 assigned to the clients.



  • In Linux:

    
    % ip -6 route
    default via fe80::209:fff:fe29:5200 dev eno1 proto static metric 100  pref medium
    
    

    In Windows:

    
    C:\>ipconfig /all
    Default Gateway . . . . . . . . . : fe80::209:fff:fe29:5200%25
    
    

    Get these default routes out of your clients and the timeouts will stop. Longer prefix routes outside of general Internet traffic won't cause timeouts.

    In pfSense, set the Router Advertisements Router Mode to Disabled. If you want to do this live, set the router mode to Router Only, then Disabled. Router Only forces clients to give up their address. Disabled makes them give up their router. This works well on Windows clients, and poorly on Linux clients.

    ipv6 connectivity will not automatically turn on when it appears at the ISP. You'll need to turn RA back on.


  • LAYER 8 Global Moderator

    If you want IPv6 until your ISP brings it online just get a HE tunnel, easy enough to setup - you can get a FREE /48 from them and there you go IPv6 no need for your isp to support it..


Log in to reply