[SOLVED] Internal Web Service not show through captive portal



  • Hello,

    Maybe the title is not so explanatory, but I'll try to do it below.

    We have:

    • pfsense as border firewall.
    • pfsense virtualized with captive portal enabled.

    In the border pfsense I have several VLANS, among them the VLAN300 which is for the servers.

    • In the VLAN300 we have the site of our institute.

    • In the VLAN300 we have our DNS that answers for our internal services.
      NOTE: All our internal services have valid IP.

    • The captiveportal WAN is a valid IP (of course :D) that is on the VLAN300.

    • The LAN is a private IP.

    The rules for ports 53, 80, and 443 are allowed from the LAN out, otherwise they would not have access to external sites.

    What happens:

    When trying to access the site of the institute (internal service) using a device connected to our captiveportal, timed out error occurs. Any other site we access normal.

    Any idea?



  • Well, at first I corrected the problem! What I did:

    I added in the /boot/loader.conf entry,

    hw.xen.disable_pv_nics = "1"
    

    The interfaces are recognized as xn0 and xn1. When adding the entry above, they become as re0 and re1.

    When restarting the server I had to assign the interfaces again.

    I do not know if the correction was made by adding the input. I just know it worked.


Log in to reply