Baby Jumbo Frames / RFC 4638



  • Hi,
    I was wondering if there are any instructions for configuring Baby Jumbo Frames for PPPOE connections?

    I'm in the UK and my ISP (AAISP) support baby jumbo frames on my FTTC (VDSL) PPPOE connection, but I can't seem to make it work on pfSense.

    I have tried setting the MTU on the physical interface to 1508 and the MTU / MRU on the PPPOE interface to 1500, but this seems to drop down to 1492 straight away. Are there any tricks to enabling this, as it would be a great help!

    Thanks
    James



  • I'm making a wild guess here but there are also MTU values associated with routes. Go to Diagnostics->Routing Table to see this.
    Maybe try increasing those?

    netstat -r
    route get <net host="">route change <net host="">-mtu 1508</net></net>



  • Thanks, will have a look into that



  • For anyone else battling with this, I think I have found the issue - see here: https://blog.kingj.net/2017/02/12/how-to/baby-jumbo-frames-rfc-4638-with-igb-based-nics-on-pfsense/

    My WAN NIC is the Intel i211, and thus the Intel igb driver is used. Reading over Intel’s documentation for their igb driver however, I noticed an interesting line;

    – Using Jumbo frames at 10 or 100 Mbps is not supported and may result in poor performance or loss of link.

    Both of the commonly supplied VDSL modems in the UK (ECI B-FOCus and Huawei HG612) only have a 10/100mbit connection – you cannot negotiate a gigabit connection. So it seems there’s two conflicting things here;

    NICs using the igb driver do not support Jumbo Frames (including Baby Jumbo Frames) at 10/100mbit speeds.
    Common VSDL modems won’t support speeds other than 10/100mbit.

    I'm using an intel quad port card, but I'm guessing it is the same driver. I will try using a gigabit unmanaged switch in between :)



  • Well this sort of worked. The interface was sitting quite happily at 1500mtu and I tested that I could ping without fragmentation:

    
    C:\Users\Administrator>ping -f -l 1472 github.com
    
    Pinging github.com [192.30.253.112] with 1472 bytes of data:
    Reply from 192.30.253.112: bytes=1472 time=86ms TTL=56
    Reply from 192.30.253.112: bytes=1472 time=86ms TTL=56
    Reply from 192.30.253.112: bytes=1472 time=87ms TTL=56
    Reply from 192.30.253.112: bytes=1472 time=87ms TTL=56
    
    Ping statistics for 192.30.253.112:
        Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
        Minimum = 86ms, Maximum = 87ms, Average = 86ms
    
    

    Which worked fine. But now this morning, it's back to 1492 and fragmenting again.

    One thing I did notice when it was working ok was that my WAN interface didn't appear to have an IPv6 address, but now it does. IPv6 was still working without it though.