SG-2220 upgrade failure



  • I have an SG-2220 that is failing the upgrade from 2.3.2-RELEASE-p1 to 2.3.3.

    Updating from the UI produces this:

    >>> Updating repositories metadata... 
    Updating pfSense-core repository catalogue...
    pfSense-core repository is up-to-date.
    Updating pfSense repository catalogue...
    pfSense repository is up-to-date.
    All repositories are up-to-date.
    ERROR: It was not possible to determine pfSense-repo remote version
    Failed
    
    

    Updating via the console produces this:

    >>> Updating repositories metadata... 
    Updating pfSense-core repository catalogue...
    pfSense-core repository is up-to-date.
    Updating pfSense repository catalogue...
    pfSense repository is up-to-date.
    All repositories are up-to-date.
    >>> Unlocking package pfSense-kernel-pfSense... done.
    The following 5 package(s) will be affected (of 0 checked):
    
    Installed packages to be UPGRADED:
    	pfSense-rc: 2.3.2_1 -> 2.3.3 [pfSense-core]
    	pfSense-kernel-pfSense: 2.3.2_1 -> 2.3.3 [pfSense-core]
    	pfSense-default-config: 2.3.2_1 -> 2.3.3 [pfSense-core]
    	pfSense-base: 2.3.2_1 -> 2.3.3 [pfSense-core]
    
    Installed packages to be REINSTALLED:
    	scponly-4.8.20110526_2 [pfSense] (options changed)
    
    Number of packages to be upgraded: 4
    Number of packages to be reinstalled: 1
    
    40 MiB to be downloaded.
    
    **** WARNING ****
    Reboot will be required!!
    Proceed with upgrade? (y/N) y
    >>> Downloading upgrade packages... 
    Updating pfSense-core repository catalogue...
    pfSense-core repository is up-to-date.
    Updating pfSense repository catalogue...
    pfSense repository is up-to-date.
    All repositories are up-to-date.
    Checking for upgrades (5 candidates): ..... done
    Processing candidates (5 candidates): ..... done
    The following 5 package(s) will be affected (of 0 checked):
    
    Installed packages to be UPGRADED:
    	pfSense-rc: 2.3.2_1 -> 2.3.3 [pfSense-core]
    	pfSense-kernel-pfSense: 2.3.2_1 -> 2.3.3 [pfSense-core]
    	pfSense-default-config: 2.3.2_1 -> 2.3.3 [pfSense-core]
    	pfSense-base: 2.3.2_1 -> 2.3.3 [pfSense-core]
    
    Installed packages to be REINSTALLED:
    	scponly-4.8.20110526_2 [pfSense] (options changed)
    
    Number of packages to be upgraded: 4
    Number of packages to be reinstalled: 1
    
    40 MiB to be downloaded.
    Fetching scponly-4.8.20110526_2.txz: .. done
    pkg: cached package scponly-4.8.20110526_2: size mismatch, fetching from remote
    Fetching scponly-4.8.20110526_2.txz: .. done
    pkg: cached package scponly-4.8.20110526_2: size mismatch, cannot continue
    >>> Locking package pfSense-kernel-pfSense... done.
    
    

    Unfortunately the unit is remote, so I can't just wipe and re-install. Ideas?

    Thanks in advance.



  • The error cleared today and the upgrade proceeded as expected.

    I'm assuming that something was fixed in the repo?


  • Banned

    Must be the butterflies encountering no loss of separation today. :P


Log in to reply