Every 10 minutes, I have 4-5s packet loss



  • I am new to the forum, please let me know if I am in the wrong area for this question.

    I have had a problem with random packet loss every 10 mins. I reinstalled my pfsense fresh yesterday morning. Back up and running. I have a ping utility showing me results for pings to 8.8.8.8 and another server on the internet. I have 2 pcs in my network testing these pings at the same time. Every 10 mins, almost to the second, I see 4-5 seconds of packet loss on both pcs.

    This morning I disconnected from behind the pfsense box and connected directly to my cable modem for the morning. I did not receive any kind of packet loss all morning.

    When I setup a ping from the pfsense box to the 8.8.8.8 address, it seems that the packet loss is greatly reduced, but still randomly occurs.

    Has anyone seen this before? Ideas about how to trace down the issue? I am running a PC Engines APU.1C4. 3 nics. I have reconfigured the unused nic and moved the LAN traffic to that nic, no change.

    I have 1 package installed - pfBlockerNG.

    Thank you for the time to respond,
    Gordon



  • This is what happened when I upgraded from latest to recent (I'm using 2.3.3 right now).

    What I did up until now :
    Switching interfaces -> no go.
    Removing all packages (I had have NUT and Avahi) -> no go.
    Removing all IPv6 (== he.net stuff) -> no go.

    What I observe is : when I reboot the pfSense, the 'apinger' ping is 18 ms solid - after two minutes or so, it start to fluctuate, indicating everything from 0 to 30 % "ping loss". See image.

    What worked : connecting my "ADSL-PPPOE" modem  directly to a PC - setting up a PPPOE access => the ping was 18 ms rock solid to the same gateway (my ISP). This means : taking pfSense out of my network solved the packet (ping) loss.

    edit : the image shows the exact time I upgraded ….




  • Have you tried playing with the Gateway Monitoring and Gateway Actions options under System - Routing - Gateways?



  • @KOM:

    Have you tried playing with the Gateway Monitoring and Gateway Actions options under System - Routing - Gateways?

    Everything is set default - except the "pay load" (in the advanced section)  set to "64", which was an advise in the past (it must be bigger as 1).



  • @Gertjan:

    Everything is set default - except the "pay load" (in the advanced section)  set to "64", which was an advise in the past (it must be bigger as 1).

    You only need to set a payload size if dpinger shows 100% loss with payload size 0. This is to work around defective icmp implementations in some routers.

    The other thing to check for is icmp rate limiting. Either change the target or change the probe interval.


Log in to reply