BTX halted - Error driving me nuts



  • :( Grrrrrr.
    This BTX halted is just (I wont swear). I had a version Unknown working, something went wrong and I couldn't log in. I have tried to mem stick install 2.2.6, 2.3.2, & 2.3.3 all come up with BTX halted.
    I have tried in BIOS to disable, parallel port, serial port, floppy drive, restore BIOS defaults, remove network cards, swap network cards, disable built in Network (realtek), just about everything but washing it with the power plugged in or adjusting it with C4.

    I'm using an ASRock P4i65G motherboard, P4 CPU, 1G RAM, SSD, No optical.

    Any useful suggestions like how to diagnose whats wrong?
    Thanks



  • UP-Date
    Memory Test passed OK
    HDD Extended Tests passed OK.
    Unable to located IDE DMA to disable Redirected to this and have read other responses in the forum - https://lists.freebsd.org/pipermail/freebsd-hardware/2003-August/000479.html

    It was working on v2.2.4 or 2.2.6 with a total of 3 NICS, 1 of which was a dual port. The other week when I plugged a cable in to re-enter web configure, (the old 100M Intel card) the interface just started scrolling some kind of error. Shortly afterwards it started to 'crash' and then not boot at all. I have tried 2.3.2 & 2.3.3 CE memstick versions installed using unetbootin (keeps jumping to FLOPPY mode), and I have tried LiLu usb creator on a friends Win7 PC, but all attempts now come up with BTX ERROR.

    [EDIT]
    From this https://doc.pfsense.org/index.php/Installation_Troubleshooting#Boot_from_hard_drive_after_CD_installation_fails
    How would I achieve this as I CAN connect the SATA drive to my other computer?
    What file do I use ?
    Thanks

    Does anyone have any suggestions, please.



  • OK Change of plan. Managed to find a working DVD burner and my last blank DVD, burned 2.2.6 .iso and it booted ok, and I was able to install. Now back to the old problem. As soon as I boot, i get the F1 to continue screen, then

    \

    And that's it. I haven't changed hardware or software, no updates as I hadn't put the unit online, as I was waiting for my new Internet connection to be finalised, and then this '' error. Then I tried to re-install the newer version 2.3.2, & 2.3.3 and now BTX Halted Error.

    I just can't win.

    Thanks if anyone responds

    [Edit] - Brought another Blank DVD and burned 2.3.3, same problem. Boots OK, Installs OK, "Press F1" Screen I get the ….


  • Banned

    You have a broken BIOS. This required some alternative loader install, no idea where/whether/how's that accessible from the current installer.


  • Rebel Alliance Developer Netgate

    Try 2.4. Completely different boot and install setup than old versions.



  • Yep the Broken BIOS would make sense, but means the Motherboard is stuffed! After alll it was working fine for 9months, and then not.

    Ver 2.4 you say, I don't see an I386 version. Bit of a bummer.

    Does anyone know how to search for the \ fault as in backslash, or if it has been mentioned before. I have searched but can't find anything directly? Or is this the same as below with "Forward slash /" ?
    As in the PC did and now does again Freezes as soon after it continues after the F1 screen.
    DOC - If everything is configured correctly the kernel will begin to load. For serial console images, systems with VGA output will stop displaying with a "/" on the screen or may stop at a "BTX" message. From that point on all output is sent to COM1

    Q2. How do I install pfsense to a HDD then install that HDD into the machine I wish to use pfsense on? As described in the DOCS
    https://doc.pfsense.org/index.php/Installation_Troubleshooting#Boot_from_Memstick_or_CD_Fails

    Thanks