Dhcpleases & unbound errors in the logs


  • Galactic Empire

    I seem to get the following errors when restarting dhcp & unbound, anyone got any ideas, it seems to be working fine ?

    Status -> System Logs -> System -> General  :-

    Feb 28 18:33:53 dhcpleases kqueue error: unkown
    Feb 28 18:33:53 dhcpleases Could not deliver signal HUP to process because its pidfile (/var/run/unbound.pid) does not exist, No such process.
    Feb 28 18:33:53 dhcpleases /var/etc/hosts changed size from original!

    Status -> System Logs -> System -> DNS Resolver :-

    Feb 28 18:33:55 unbound 31461:0 info: start of service (unbound 1.6.0).
    Feb 28 18:33:55 unbound 31461:0 notice: init module 1: iterator
    Feb 28 18:33:55 unbound 31461:0 notice: init module 0: validator
    Feb 28 18:33:55 unbound 31461:0 error: cannot chdir to directory: (No such file or directory)
    Feb 28 18:33:55 unbound 31461:0 notice: Restart of unbound 1.6.0.

    [2.3.3-RELEASE][admin@pfsense]/var/run: more unbound.pid
    31461

    [2.3.3-RELEASE][admin@pfsense]/var/run: ps -ax | grep 31461
    31461  -  Ss    0:03.11 /usr/local/sbin/unbound -c /var/unbound/unbound.conf
    54408  0  S+    0:00.00 grep 31461

    [2.3.3-RELEASE][admin@pfsense]/var/run: ls -alg unbound.pid
    -rw-r–r--  1 root  wheel  6 Feb 28 18:33 unbound.pid



  • I have the same problem.

    Infos :

    2.4.0.b.20170228.1316 on ZFS and I use DNS resolver

    It's only 3 days that I use pfsense so I don't know what information would be useful.
    Tell me if I can help.

    And by the way pfsense is really awesome.  8)



  • I have the same logs in unbound.
    every morning after the 24h Provider reconnect i have to start unbound manually :(

    do you use dnsbl?



  • No DNSBL here.


  • Galactic Empire

    @renegade:

    I have the same logs in unbound.
    every morning after the 24h Provider reconnect i have to start unbound manually :(

    do you use dnsbl?

    Nope, but after further searching the forums a few people seem to be seeing it.

    I've not seen any issues with my router, maybe I'm a bit too OCD and should stop looking in the logs :)

    https://redmine.pfsense.org/issues/7326 << someones created a redmine.



  • Same issues here, only extra i got is snort IDS installed on PfSense.

    Mar 1 09:03:08 dhcpd Internet Systems Consortium DHCP Server 4.3.5
    Mar 1 09:03:07 dhcpleases Sending HUP signal to dns daemon(16480)
    Mar 1 09:03:07 dhcpleases kqueue error: unkown
    Mar 1 09:03:07 dhcpleases Could not deliver signal HUP to process because its pidfile (/var/run/unbound.pid) does not exist, No such process.
    Mar 1 09:03:07 dhcpleases Sending HUP signal to dns daemon(2298)
    Mar 1 09:03:07 dhcpleases /var/etc/hosts changed size from original!
    Mar 1 09:03:05 dhcpleases Sending HUP signal to dns daemon(2298)
    Mar 1 09:03:05 dhcpleases Sending HUP signal to dns daemon(2298)
    Mar 1 09:03:05 dhcpd Server starting service.



  • I've noticed similar entries when troubleshooting my problem ( https://forum.pfsense.org/index.php?topic=126762.0 ). I've removed snort and pfblocker and the errors didn't show up anymore.