No DHCP on VLAN interfaces



  • I'm attempting to create a new VLAN configuration on pfSense 2.3.3, and can't get DHCP Server to configure.

    According to what I've been reading,  after configuring VLANs,  I should be able to go to SERVICES | DHCP SERVER and find the correct VLAN to configure.  Unfortunately,  none of the VLANs show up there.

    Congratulations to iceflatline for the best VLAN "How To" document I've seen for pfSense.  Of course, he was using rel. 2.1.2, and I can't get those same instructions to work on 2.3.3.   
    https://www.iceflatline.com/2013/09/how-to-create-and-configure-vlans-in-pfsense/

    This used to work in previous versions, because I have my personal notes on how I did this previously.  So either the configuration has changed, or I failed to note something that allows a VLAN to have a DHCP Server.  Suggestions?


  • Rebel Alliance Global Moderator

    To create a vlan takes all of like 3 seconds.  Interfaces assign, vlans - add.. Pick your parent interfaces, put in your tag number.  Done.

    You then need to assign it.. Give it an IP…

    Once you do that then yes dhcp server can be enabled on that vlan interface you just created.  It really is that simple!






  • @Gord:

    after configuring VLANs,  I should be able to go to SERVICES | DHCP SERVER and

    You probably just forgot to enable the new interface and assign it an IP/network. DHCP server is only available after that. johnpoz showed it in his second screenshot.



  • Found my mistake.  I had created the VLANs under INTERFACE | ASSIGN |  VLAN,
    but had failed to create them under **INTERFACE | ASSIGN | INTERFACE ASSIGNMENTS. **

    It was this second assignment that allowed me to enter an IP address, which then allowed DHCP to be configured on that VLAN.

    I also found out that if I logged in to read johnpoz reply,  I would have seen those screen prints.  The screen prints do not show if I only click on the link in the notification email.  Thanks to jahonix for bringing that to my attention.

    Thank you to johnpoz and jahonix for guiding me back to reality.  Problem Solved.



  • Hi All!

    I'am quite new here and face the same problem!
    I have exactly followed the steps from the screenshot, but i still don't see any other/new interfaces appearing.

    For sure:

    • Created a VLAN on the Parent LAN-Interface (VLAN 99) (via Interface -> VLAN)
    • I Added a new interface named "Guests" based on the just created VLAN99
    • Enabled the Interface and set IPV4 (static) address 192.168.179.1/24
    • SAVED the config and reloaded

    But once i go to the DHCP Service page, i only see the "LAN"-tab, but not the newly created "Guests" interface.

    In your screenshots i also see the "WAN" for example.. i only have LAN.

    What am i missing? is there another setting which prevents the creation of the "Guest" tab in the DHCP server settings?


  • Rebel Alliance Global Moderator

    "Created a VLAN on the Parent LAN-Interface (VLAN 99) (via Interface -> VLAN)"

    what is interface vlan??  The parent interface would be an actual physical interface, em0, re1, igb0, etc..

    Yeah you have to be logged into to via attachments ;)




  • Hmmm suddenly i appeared… i tried this already many times.. :(
    This time i rebooted my box and it appeared :)

    On all tutorials/video's i saw the DHCP on the new Interface directly appearing. But it seems that it took some extra time on my box.



  • VLAN's interface subnet mask (CIDR notation) should also something less than 32 bit for DHCP server to start.



  • @begbis:

    VLAN's interface subnet mask (CIDR notation) should also something less than 32 bit for DHCP server to start.

    This is what did it for me, note that the default subnet CIDR is /32 (which is a single IP address).

    After I experienced the same issue – creating a vLAN (Interfaces > VLANs), assigning it to a new subinterface (Interfaces > Interface Assignments), enabling the interface and setting a static IPv4 address -- I read this post and changed the subnet to /24 on the interface configuration, saved and applied the change, and the interface finally appeared in the Services > DHCP Server config.



  • @scattermammoth:

    @begbis:

    VLAN's interface subnet mask (CIDR notation) should also something less than 32 bit for DHCP server to start.

    This is what did it for me, note that the default subnet CIDR is /32 (which is a single IP address).

    After I experienced the same issue – creating a vLAN (Interfaces > VLANs), assigning it to a new subinterface (Interfaces > Interface Assignments), enabling the interface and setting a static IPv4 address -- I read this post and changed the subnet to /24 on the interface configuration, saved and applied the change, and the interface finally appeared in the Services > DHCP Server config.

    Worked for me as well. Thanks



  • If you are doing L3 routing on FW correctly, then it should work without any problem.

    Please do the trace route from your AP