2.3.3 upgrade failure "Operation timed out"



  • I tried to upgrade from 2.3.2-p1. The last lines in the upgrade log are:

    Fetching php-suhosin-0.9.38_3.txz: ...... done
    Fetching pftop-0.7_7.txz: ...... done
    Fetching pfSense-rc-2.3.3.txz: . done
    Fetching pfSense-kernel-pfSense-2.3.3.txz: ...... done
    pkg: https://pkg.pfsense.org/pfSense_v2_3_3_amd64-core/All/pfSense-kernel-pfSense-2.3.3.txz: Operation timed out
    >>> Locking package pfSense-kernel-pfSense... done.
    __RC=1 __REBOOT_AFTER=10
    

    Operation timed out? Someone recognize this? What can I do? Try again and hope I'm lucky?



  • I'm also seeing this same error with multiple pfSense production routers.

    Is there anyway wget (or similar) could be used to force the package to download, &/or add additional mirror repositories?
    Is it also worth cleaning out the partial download before reattempting the upgrade?



  • Had a message saying that i was using a newer version than released or something like that… Using 2.3.3-Release atm, and get this weird thing when i go into the update page.

    Version 2.3.3-RELEASE (amd64)
    built on Thu Feb 16 06:59:53 CST 2017
    FreeBSD 10.3-RELEASE-p16

    The system is on a later version than
    the official release.

    Is the message on the dashboard.

    C




  • Se Redmine https://redmine.pfsense.org/issues/7343 for progress about this.